File varnish.spec of Package varnish

#
# spec file for package varnish
#
# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           varnish
%define library_name libvarnishapi1
Version:        4.0.3
Release:        0
Summary:        Varnish is a high-performance HTTP accelerator
License:        BSD-2-Clause
Group:          Productivity/Networking/Web/Proxy
Url:            http://varnish-cache.org/

#Git-Clone:	git://git.varnish-cache.org/varnish-cache
#Git-Web:	https://varnish-cache.org/trac/browser
Source:		https://repo.varnish-cache.org/source/%name-%version.tar.gz
Source3:        varnish.sysconfig
Source5:        varnish.logrotate
Source7:        varnish.service
Source8:        varnishlog.service
Patch1:         0001-Fail-fetch-on-malformed-Content-Length-header.patch

BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildRequires:  libxslt
BuildRequires:  ncurses-devel
BuildRequires:  pcre-devel
BuildRequires:  pkgconfig
BuildRequires:  readline-devel
BuildRequires:  python-docutils
BuildRequires:  xz
Prereq(post):	%_sbindir/useradd %_sbindir/groupadd
%if 0%{?suse_version} >= 1010
Recommends:     logrotate
%endif
BuildRequires:  systemd-rpm-macros
%define pkg_home     %_localstatedir/lib/%name
%define pkg_logdir   %_localstatedir/log/%name
%define pkg_cachedir %_localstatedir/cache/%name
Requires:       c_compiler

%description
Varnish is an HTTP accelerator. An HTTP accelerator (often called Reverse
Proxy) is an application that stores (caches) documents that have been
requested over the HTTP protocol.

Based on certain criteria the next client requesting the document is either
given the cached document, or a "fresh" document requested from a backend
server. The purpose of this is to minimize the requests going to the backend
server(s) by serving the same document to potentially many users.

%package -n %library_name
Summary:        Shared libraries for Varnish
Group:          Productivity/Networking/Web/Proxy

%description -n %library_name
Varnish is an HTTP accelerator. An HTTP accelerator (often called Reverse
Proxy) is an application that stores (caches) documents that have been
requested over the HTTP protocol.

Based on certain criteria the next client requesting the document is either
given the cached document, or a "fresh" document requested from a backend
server. The purpose of this is to minimize the requests going to the backend
server(s) by serving the same document to potentially many users.

This package holds the shared libraries for varnish.

%package devel
Requires:       %name = %version
Summary:        Development files for Varnish
Group:          Development/Libraries/C and C++

%description devel
Varnish is an HTTP accelerator. An HTTP accelerator (often called Reverse
Proxy) is an application that stores (caches) documents that have been
requested over the HTTP protocol.

Based on certain criteria the next client requesting the document is either
given the cached document, or a "fresh" document requested from a backend
server. The purpose of this is to minimize the requests going to the backend
server(s) by serving the same document to potentially many users.

This package holds the development files for varnish.

%prep
%setup -q
%patch -P 1 -p1

%build
export CFLAGS="%optflags -fstack-protector"
%configure --disable-static --docdir="%_docdir/%name" \
           --localstatedir=%_localstatedir/cache/ \
           --enable-developer-warnings
make %{?_smp_mflags}

%install
b="%buildroot";
%make_install
# There is no use for them to normal users
mv "$b/%_bindir"/* "$b/%_sbindir/";
#
##missing directories
install -dm 0755 "$b"/{%pkg_logdir,%pkg_home};
install -Dpm 0644 "%{S:5}" "$b/%_sysconfdir/logrotate.d/varnish";
#
##init scripts
install -Dpm 0644 "%{S:3}" "$b/var/adm/fillup-templates/sysconfig.%name";
install -Dpm 0644 "%{S:7}" "$b/%_unitdir/varnish.service";
install -Dpm 0644 "%{S:8}" "$b/%_unitdir/varnishlog.service";
mkdir -p "$b/%_sbindir";
ln -s service "$b/%_sbindir/rcvarnish";
ln -s service "$b/%_sbindir/rcvarnishlog";
#
##config files
mkdir -p "$b/%_sysconfdir/%name"
cp "$b/%_docdir/%name/example.vcl" "$b/%_sysconfdir/%name/vcl.conf"

find "$b" -type f -name "*.la" -delete
mkdir -p "$b/%pkg_logdir"
mkdir -p "$b/%_docdir/%name"
cp -a ChangeLog LICENSE README "$b/%_docdir/%name/"

%pre
%_bindir/getent group varnish >/dev/null || \
	%_sbindir/groupadd -r varnish || :
%_bindir/getent passwd varnish >/dev/null || \
	%_sbindir/useradd -g varnish -s /bin/false -r -c "user for Varnish" \
		-d %pkg_home varnish || :
%service_add_pre varnish.service
%service_add_pre varnishlog.service

%post
%service_add_post varnish.service
%service_add_post varnishlog.service

%preun
%service_del_preun varnish.service
%service_del_preun varnishlog.service

%postun
%service_del_postun varnish.service
%service_del_postun varnishlog.service

%post   -n %library_name -p /sbin/ldconfig
%postun -n %library_name -p /sbin/ldconfig

%files
%defattr(-,root,root)
%_unitdir/*.service
%config(noreplace) %_sysconfdir/logrotate.d/varnish
%dir %attr(0750,root,varnish) %_sysconfdir/%name/
%config(noreplace) %attr(0640,root,varnish) %_sysconfdir/%name/vcl.conf
%_libdir/varnish
%_sbindir/varnish*
%_sbindir/rcvarnish*
%_mandir/man*/*
%_docdir/%name/
%_datadir/%name/
%dir %attr(0750,varnish,varnish) %pkg_home
%dir %attr(0750,varnish,varnish) %pkg_cachedir
%dir %attr(0750,varnish,varnish) %pkg_logdir
%_localstatedir/adm/fillup-templates/sysconfig.%name

%files -n %library_name
%defattr(-,root,root,-)
%_libdir/libvarnishapi.so.1*

%files devel
%defattr(-,root,root,-)
%_includedir/varnish
%_datadir/aclocal/
%_libdir/pkgconfig/*
%_libdir/libvarnishapi.so

%changelog
openSUSE Build Service is sponsored by