File ilmbase.spec of Package ilmbase

#
# spec file for package ilmbase
#
# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%global so_suffix -2_1-11

Name:           ilmbase
Version:        2.1.0
Release:        0
Summary:        Base library for ILM software (OpenEXR)
License:        BSD-3-Clause
Group:          Development/Libraries/C and C++
Url:            http://www.openexr.com
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
Source0:        http://download.savannah.nongnu.org/releases/openexr/%{name}-%{version}.tar.gz
Source1:        http://download.savannah.nongnu.org/releases/openexr/%{name}-%{version}.tar.gz.sig
Source2:        baselibs.conf
Source3:        ilmbase.keyring
Patch0:         arm-build.diff
Patch1:         fix-i586.patch
BuildRequires:  autoconf
BuildRequires:  automake
BuildRequires:  gcc-c++
BuildRequires:  libtool
BuildRequires:  pkg-config
# Renamed to libilmbase6 to met the Shared Library Policy
Obsoletes:      IlmBase <= 1.0.1
Provides:       IlmBase = %{version}

%description
Base library for Industrial Light & Magic software (OpenEXR).

* Half is a class that encapsulates our 16-bit floating-point
   format.

* IlmThread is a thread abstraction library for use with OpenEXR and
   other software packages.  It currently supports pthreads and
   Windows threads.

* Imath implements 2D and 3D vectors, 3x3 and 4x4 matrices,
   quaternions and other useful 2D and 3D math functions.

* Iex is an exception-handling library.

%package devel
Requires:       libHalf11
Requires:       libIex%{so_suffix}
Requires:       libIexMath%{so_suffix}
Requires:       libIlmThread%{so_suffix}
Requires:       libImath%{so_suffix}
Requires:       libstdc++-devel
Summary:        Base library for ILM software (OpenEXR)
License:        BSD-3-Clause and GPL-2.0+
Group:          Development/Libraries/C and C++
# Renamed to libilmbase6 to met the Shared Library Policy
Obsoletes:      IlmBase-devel <= 1.0.1
Provides:       IlmBase-devel = %{version}
Obsoletes:      libilmbase-devel <= 1.0.2
Provides:       libilmbase-devel = %{version}

%description devel
Devel files for ilmbase 
Base library for Industrial Light & Magic software (OpenEXR).

%files devel
%defattr(-,root,root)
%doc AUTHORS ChangeLog COPYING NEWS README*
%{_includedir}/OpenEXR
%_libdir/libHalf.so
%_libdir/libIex.so
%_libdir/libImath.so
%_libdir/libIlmThread.so
%_libdir/libIexMath.so
%_libdir/pkgconfig/IlmBase.pc

%package -n libHalf11
Summary:        Base library for ILM software (OpenEXR)
License:        BSD-3-Clause
Group:          Development/Libraries/C and C++

%description -n libHalf11
%{summary}.

%post -n libHalf11 -p /sbin/ldconfig

%postun -n libHalf11 -p /sbin/ldconfig

%files -n libHalf11
%defattr(-,root,root,-)
%{_libdir}/libHalf.so.*

%package -n libIexMath%{so_suffix}
Summary:        Base library for ILM software (OpenEXR)
License:        BSD-3-Clause
Group:          Development/Libraries/C and C++

%description -n libIexMath%{so_suffix}
%{summary}.

%post -n libIexMath%{so_suffix} -p /sbin/ldconfig

%postun -n libIexMath%{so_suffix} -p /sbin/ldconfig

%files -n libIexMath%{so_suffix}
%defattr(-,root,root,-)
%{_libdir}/libIexMath*.so.*

%package -n libIex%{so_suffix}
Summary:        Base library for ILM software (OpenEXR)
License:        BSD-3-Clause
Group:          Development/Libraries/C and C++

%description -n libIex%{so_suffix}
%{summary}.

%post -n libIex%{so_suffix} -p /sbin/ldconfig

%postun -n libIex%{so_suffix} -p /sbin/ldconfig

%files -n libIex%{so_suffix}
%defattr(-,root,root,-)
%{_libdir}/libIex-*.so.*

%package -n libIlmThread%{so_suffix}
Summary:        Base library for ILM software (OpenEXR)
License:        BSD-3-Clause
Group:          Development/Libraries/C and C++

%description -n libIlmThread%{so_suffix}
%{summary}.

%post -n libIlmThread%{so_suffix} -p /sbin/ldconfig

%postun -n libIlmThread%{so_suffix} -p /sbin/ldconfig

%files -n libIlmThread%{so_suffix}
%defattr(-,root,root,-)
%{_libdir}/libIlmThread*.so.*

%package -n libImath%{so_suffix}
Summary:        Base library for ILM software (OpenEXR)
License:        BSD-3-Clause
Group:          Development/Libraries/C and C++

%description -n libImath%{so_suffix}
%{summary}.

%post -n libImath%{so_suffix} -p /sbin/ldconfig

%postun -n libImath%{so_suffix} -p /sbin/ldconfig

%files -n libImath%{so_suffix}
%defattr(-,root,root,-)
%{_libdir}/libImath*.so.*

%prep
%{?gpg_verify: %gpg_verify %{S:1}}
%setup -q
%patch0
%patch1 -p1

# remove a non unix READMEs
rm README.win32

%build
./bootstrap
export PTHREAD_LIBS="-lpthread"
%configure --disable-static --with-pic
make %{?_smp_mflags}

%install
%{makeinstall}
rm -f %{buildroot}%{_libdir}/*.la

%check
#XXX: workaround for a build fail with gcc45 with -02 on i586
%if 0%{?suse_version} >= 1130
%ifarch %ix86
make CXXFLAGS="`echo "%{optflags}" | sed 's/O2/O1/'`" check
%endif
%endif
make check

%clean
rm -rf %{buildroot}

%changelog
openSUSE Build Service is sponsored by