File cervisia.spec of Package cervisia
#
# spec file for package cervisia
#
# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%bcond_without lang
Name: cervisia
Version: 17.04.2
Release: 0
%define kf5_version 5.26.0
# Latest stable Applications (e.g. 16.08 in KA, but 16.11.80 in KUA)
%{!?_kapp_version: %global _kapp_version %(echo %{version}| awk -F. '{print $1"."$2}')}
Summary: CVS Frontend
License: GPL-2.0 and GFDL-1.2 and LGPL-2.0
Group: Development/Tools/Version Control
Url: http://www.kde.org
Source0: %{name}-%{version}.tar.xz
BuildRequires: extra-cmake-modules
BuildRequires: kdbusaddons-devel
BuildRequires: kdesu-devel
BuildRequires: kdoctools-devel
BuildRequires: kiconthemes-devel
BuildRequires: kinit-devel
BuildRequires: kitemviews-devel
BuildRequires: knotifications-devel
BuildRequires: kparts-devel
BuildRequires: kwidgetsaddons-devel
BuildRequires: pkgconfig
BuildRequires: subversion-devel
BuildRequires: update-desktop-files
BuildRequires: pkgconfig(Qt5Core)
BuildRequires: pkgconfig(Qt5DBus)
BuildRequires: pkgconfig(Qt5Widgets)
Recommends: %{name}-lang
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%description -n cervisia
Cervisia is a to work with and browse in CVS repositories.
%if %{with lang}
%lang_package
%endif
%prep
%setup -q
%build
%ifarch ppc64
RPM_OPT_FLAGS="%{optflags} -mminimal-toc"
%endif
export CXXFLAGS="%{optflags} -fPIC"
export CFLAGS="%{optflags} -fPIC"
%cmake_kf5 -d build -- -DCMAKE_CXXFLAGS="%{optflags}" -DCMAKE_CFLAGS="%{optflags}"
%make_jobs
%install
%kf5_makeinstall -C build
%if %{with lang}
%find_lang %{name} --with-man --all-name
%kf5_find_htmldocs
%endif
%suse_update_desktop_file org.kde.cervisia5 Development RevisionControl
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%defattr(-,root,root)
%doc COPYING COPYING.DOC COPYING.LIB ChangeLog README
%{_bindir}/cervisia
%{_bindir}/cvsaskpass
%{_bindir}/cvsservice5
%{_libdir}/libkdeinit5_cervisia.so
%{_libdir}/libkdeinit5_cvsaskpass.so
%{_libdir}/libkdeinit5_cvsservice.so
%{_kf5_plugindir}/cervisiapart5.so
%dir %{_kf5_appstreamdir}
%{_kf5_appstreamdir}/org.kde.cervisia.appdata.xml
%{_kf5_applicationsdir}/org.kde.cervisia5.desktop
%dir %{_kf5_configkcfgdir}/
%{_kf5_configkcfgdir}/cervisiapart.kcfg
%{_datadir}/dbus-1/interfaces/org.kde.cervisia5.*.xml
%{_kf5_htmldir}/en/cervisia/
%{_kf5_iconsdir}/hicolor/*/*/*
%{_kf5_servicesdir}/org.kde.cervisiapart5.desktop
%{_kf5_servicesdir}/org.kde.cvsservice5.desktop
%{_kf5_kxmlguidir}/cervisia/
%{_kf5_kxmlguidir}/cervisiapart/
%{_mandir}/man1/cervisia.1%{ext_man}
%{_kf5_notifydir}/cervisia.notifyrc
%if %{with lang}
%files lang -f %{name}.lang
%doc COPYING*
%endif
%changelog