File ghc-spool.spec of Package ghc-spool
#
# spec file for package ghc-spool
#
# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%global pkg_name spool
Name: ghc-%{pkg_name}
Version: 0.1
Release: 0
Summary: Convert between ByteString and Vector.Storable without copying
License: BSD-3-Clause
Group: System/Libraries
Url: https://hackage.haskell.org/package/%{pkg_name}
Source0: https://hackage.haskell.org/package/%{pkg_name}-%{version}/%{pkg_name}-%{version}.tar.gz
BuildRequires: ghc-Cabal-devel
# Begin cabal-rpm deps:
BuildRequires: ghc-bytestring-devel
BuildRequires: ghc-rpm-macros
BuildRequires: ghc-vector-devel
BuildRoot: %{_tmppath}/%{name}-%{version}-build
# End cabal-rpm deps
%description
This library allows conversion between the types from 'Data.ByteString'
(package 'bytestring') and 'Data.Vector.Storable' (package 'vector') without
copying the underlying data. This is useful, for example, when 'ByteString' IO
produces or consumes vectors of numbers in native byte order.
This trick relies on the fact that 'ByteString' and 'Vector' use their
respective 'ForeignPtr's in compatible ways. It works with
'bytestring-0.9.1.10' and 'vector-0.9' on GHC 7.0. It may break with future
releases of these packages. Depending on this library should be seen as a way
to document and standardize an existing hack, and not as an absolute guarantee
of correct behavior.
%package devel
Summary: Haskell %{pkg_name} library development files
Group: Development/Libraries/Other
Requires: %{name} = %{version}-%{release}
Requires: ghc-compiler = %{ghc_version}
Requires(post): ghc-compiler = %{ghc_version}
Requires(postun): ghc-compiler = %{ghc_version}
%description devel
This package provides the Haskell %{pkg_name} library development files.
%prep
%setup -q -n %{pkg_name}-%{version}
%build
%ghc_lib_build
%install
%ghc_lib_install
%post devel
%ghc_pkg_recache
%postun devel
%ghc_pkg_recache
%files -f %{name}.files
%defattr(-,root,root,-)
%doc LICENSE
%files devel -f %{name}-devel.files
%defattr(-,root,root,-)
%doc README
%changelog