File gtkmm3.spec of Package gtkmm3
#
# spec file for package gtkmm3
#
# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
# Update baselibs.conf when changing this
%define so_ver -3_0-1
Name: gtkmm3
%define _name gtkmm
Version: 3.20.1
Release: 0
Summary: C++ Interface for GTK3 (a GUI Library for X)
License: LGPL-2.1+
Group: System/Libraries
Url: http://www.gtkmm.org/
Source0: http://download.gnome.org/sources/gtkmm/3.20/%{_name}-%{version}.tar.xz
Source99: baselibs.conf
BuildRequires: doxygen
BuildRequires: fdupes
BuildRequires: gcc-c++
BuildRequires: xsltproc
BuildRequires: pkgconfig(atkmm-1.6) >= 2.24.1
BuildRequires: pkgconfig(cairomm-1.0) >= 1.12.0
BuildRequires: pkgconfig(epoxy) >= 1.2
BuildRequires: pkgconfig(gdk-pixbuf-2.0) >= 2.26.0
BuildRequires: pkgconfig(giomm-2.4) >= 2.48.0
BuildRequires: pkgconfig(gtk+-3.0) >= 3.20.0
BuildRequires: pkgconfig(pangomm-1.4) >= 2.38.2
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%description
Gtkmm provides a C++ interface to the GTK+ GUI library. gtkmm3 wraps
GTK+ 3. Highlights include typesafe callbacks, widgets extensible via
inheritance, and a comprehensive set of widget classes that can be
freely combined to quickly create complex user interfaces.
%package -n libgtkmm%{so_ver}
Summary: C++ Interface for GTK3 (a GUI library for X)
License: LGPL-2.1+
Group: System/Libraries
%description -n libgtkmm%{so_ver}
Gtkmm provides a C++ interface to the GTK+ GUI library. gtkmm3 wraps
GTK+ 3. Highlights include typesafe callbacks, widgets extensible via
inheritance and a comprehensive set of widget classes that can be
freely combined to quickly create complex user interfaces.
%package devel
Summary: C++ Interface for GTK3 (a GUI library for X)
License: LGPL-2.1+
Group: Development/Libraries/C and C++
Requires: libgtkmm%{so_ver} = %{version}
%description devel
Gtkmm provides a C++ interface to the GTK+ GUI library. gtkmm3 wraps
GTK+ 3. Highlights include typesafe callbacks, widgets extensible via
inheritance and a comprehensive set of widget classes that can be
freely combined to quickly create complex user interfaces.
%package doc
Summary: C++ Interface for GTK3 (a GUI Library for X)
License: GPL-2.0+ and LGPL-2.1+
Group: Documentation/HTML
Requires: glibmm2-doc
BuildArch: noarch
%description doc
Gtkmm provides a C++ interface to the GTK+ GUI library. gtkmm3 wraps
GTK+ 3. Highlights include typesafe callbacks, widgets extensible via
inheritance, and a comprehensive set of widget classes that can be
freely combined to quickly create complex user interfaces.
%prep
%setup -q -n %{_name}-%{version}
%build
%configure --disable-static
make %{?jobs:-j%jobs}
%install
%makeinstall
rm %buildroot/%{_libdir}/*.la
%fdupes %buildroot
%clean
rm -rf %buildroot
%post -n libgtkmm%{so_ver} -p /sbin/ldconfig
%postun -n libgtkmm%{so_ver} -p /sbin/ldconfig
%files -n libgtkmm%{so_ver}
%defattr (-, root, root)
%doc AUTHORS COPYING ChangeLog NEWS README
%{_libdir}/libgdkmm-3.0.so.*
%{_libdir}/libgtkmm-3.0.so.*
%files devel
%defattr (-, root, root)
%{_includedir}/gdkmm-3.0/
%{_includedir}/gtkmm-3.0/
%{_libdir}/*.so
%{_libdir}/pkgconfig/gdkmm-3.0.pc
%{_libdir}/pkgconfig/gtkmm-3.0.pc
%{_libdir}/gdkmm-3.0/
%{_libdir}/gtkmm-3.0/
%files doc
%defattr (-, root, root)
%{_datadir}/devhelp/books/gtkmm-3.0/
%{_datadir}/doc/gtkmm-3.0/
# Avoid BuildRequires on devhelp
%dir %{_datadir}/devhelp
%dir %{_datadir}/devhelp/books
%changelog