File khotkeys5.spec of Package khotkeys5
#
# spec file for package khotkeys5
#
# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%bcond_without lang
Name: khotkeys5
Version: 5.8.7
Release: 0
# Full Plasma 5 version (e.g. 5.8.7)
%{!?_plasma5_bugfix: %global _plasma5_bugfix %{version}}
# Lasted ABI-stable Plasma (e.g. 5.8 in KF5, but 5.8.90 in KUF)
%{!?_plasma5_version: %global _plasma5_version %(echo %{_plasma5_bugfix} | awk -F. '{print $1"."$2}')}
Summary: KDE's hotkey daemon
License: GPL-2.0+
Group: System/GUI/KDE
Url: http://www.kde.org
Source: http://download.kde.org/stable/plasma/%{version}/khotkeys-%{version}.tar.xz
BuildRequires: extra-cmake-modules >= 1.1.0
BuildRequires: kf5-filesystem
BuildRequires: xz
BuildRequires: cmake(KF5DBusAddons)
BuildRequires: cmake(KF5GlobalAccel)
BuildRequires: cmake(KF5I18n)
BuildRequires: cmake(KF5KCMUtils)
BuildRequires: cmake(KF5KDELibs4Support)
BuildRequires: cmake(KF5KIO)
BuildRequires: cmake(KF5Plasma)
BuildRequires: cmake(KF5XmlGui)
BuildRequires: cmake(LibKWorkspace) >= %{_plasma5_version}
BuildRequires: cmake(Qt5X11Extras) >= 5.4.0
BuildRequires: pkgconfig(x11)
%if %{with lang}
Recommends: %{name}-lang
%endif
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%description
KDE's hotkey daemon.module It allows you to configure custom
keyboard shortcuts and mouse gestures.
%package devel
Summary: KDE's hotkey daemon
Group: Development/Libraries/KDE
Requires: %{name} = %{version}
Conflicts: kdebase4-workspace-devel
%description devel
KDE's hotkey daemon.module It allows you to configure custom
keyboard shortcuts and mouse gestures. Development files.
%lang_package
%prep
%setup -q -n khotkeys-%{version}
%build
%cmake_kf5 -d build -- -DCMAKE_INSTALL_LOCALEDIR=%{_kf5_localedir}
%make_jobs
%install
%kf5_makeinstall -C build
%if %{with lang}
%kf5_find_lang
%endif
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%defattr(-,root,root)
%doc COPYING*
%{_kf5_libdir}/libkhotkeysprivate.so.*
%{_kf5_plugindir}/
%dir %{_kf5_htmldir}/en
%dir %{_kf5_htmldir}
%doc %{_kf5_htmldir}/en/kcontrol/
%{_kf5_sharedir}/khotkeys/
%{_kf5_servicesdir}/
%files devel
%defattr(-,root,root)
%doc COPYING*
%{_kf5_libdir}/cmake/KHotKeysDBusInterface/
%{_kf5_sharedir}/dbus-1/interfaces/org.kde.khotkeys.xml
%if %{with lang}
%files lang -f %{name}.lang
%endif
%changelog