File python-Fabric.spec of Package python-Fabric

#
# spec file for package python-Fabric
#
# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           python-Fabric
Version:        1.10.1
Release:        0
Summary:        Fabric is a simple, Pythonic tool for remote execution and deployment
License:        BSD-2-Clause
Group:          Development/Languages/Python
Url:            http://fabfile.org
Source:         https://pypi.python.org/packages/source/F/Fabric/Fabric-%{version}.tar.gz
BuildRequires:  python-devel
BuildRequires:  python-setuptools
# Test requirements:
#TODO: Disabled due to errors / fudge requirement
#BuildRequires:  python-fudge
#BuildRequires:  python-nose
# Documentation requirements:
BuildRequires:  python-Sphinx
BuildRequires:  python-paramiko >= 1.10
Requires:       python-paramiko >= 1.10
Requires:       python-setuptools
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
%if 0%{?suse_version} && 0%{?suse_version} <= 1110
%{!?python_sitelib: %global python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
%else
BuildArch:      noarch
%endif

%description
Fabric is a Python (2.5 or higher) library and command-line tool for
streamlining the use of SSH for application deployment or systems
administration tasks.

It provides a basic suite of operations for executing local or remote shell
commands (normally or via sudo) and uploading/downloading files, as well as
auxiliary functionality such as prompting the running user for input, or
aborting execution.

Typical use involves creating a Python module containing one or more functions,
then executing them via the fab command-line tool. Below is a small but
complete "fabfile" containing a single task:

    from fabric.api import run

    def host_type():
        run('uname -s')

Once a task is defined, it may be run on one or more servers, like so:

    $ fab -H localhost,linuxbox host_type
    [localhost] run: uname -s
    [localhost] out: Darwin
    [linuxbox] run: uname -s
    [linuxbox] out: Linux

    Done.
    Disconnecting from localhost... done.
    Disconnecting from linuxbox... done.

In addition to use via the fab tool, Fabric's components may be imported
into other Python code, providing a Pythonic interface to the SSH protocol
suite at a higher level than that provided by e.g. Paramiko (which
Fabric itself leverages.)

%prep
%setup -q -n Fabric-%{version}
#sed -i "s|fudge<1.0|fudge|" setup.py # Try testing with newer fudge

%build
python setup.py build
python setup.py build_sphinx --source-dir=sites/docs && rm -r build/sphinx/html/.buildinfo

%install
python setup.py install --prefix=%{_prefix} --root=%{buildroot}

#%%check
#python setup.py test

%files
%defattr(-,root,root,-)
%doc AUTHORS LICENSE README.rst build/sphinx/html
%{_bindir}/fab
%{python_sitelib}/*

%changelog
openSUSE Build Service is sponsored by