File python-celery.spec of Package python-celery
#
# spec file for package python-celery
#
# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: python-celery
Version: 3.1.19
Release: 0
Url: http://celeryproject.org
Summary: Distributed Task Queue
License: BSD-3-Clause
Group: Development/Languages/Python
Source: https://pypi.python.org/packages/source/c/celery/celery-%{version}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-build
BuildRequires: python-SQLAlchemy
BuildRequires: python-billiard >= 3.3.0.21
BuildRequires: python-cl
BuildRequires: python-curses
BuildRequires: python-dateutil
BuildRequires: python-devel
BuildRequires: python-eventlet
BuildRequires: python-gevent
BuildRequires: python-kombu >= 3.0.29
BuildRequires: python-mock
BuildRequires: python-nose-cover3
BuildRequires: python-pyOpenSSL
BuildRequires: python-pytz
BuildRequires: python-setuptools
BuildRequires: python-unittest2
%if 0%{?suse_version} == 1110
BuildRequires: python-importlib
BuildRequires: python-ordereddict
BuildRequires: python-unittest2
Requires: python-importlib
Requires: python-ordereddict
%endif
Requires: python-anyjson
Requires: python-billiard >= 3.3.0.20
Requires: python-dateutil
Recommends: python-curses
Recommends: python-pyOpenSSL
Suggests: python-eventlet
Suggests: python-gevent
Suggests: python-pymongo
Suggests: python-python-daemon
Suggests: python-pytyrant
%if 0%{?suse_version} && 0%{?suse_version} <= 1110
%{!?python_sitelib: %global python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
%py_requires
%else
BuildArch: noarch
%endif
%description
Celery is an open source asynchronous task queue/job queue based on
distributed message passing. It is focused on real-time operation,
but supports scheduling as well.
%prep
%setup -q -n celery-%{version}
%build
python setup.py build
%install
python setup.py install --prefix=%{_prefix} --root=%{buildroot}
%if 0%{?suse_version} > 1110
%check
python setup.py -q test
%endif
%files
%defattr(-,root,root,-)
%{python_sitelib}/*
%doc Changelog README.rst TODO LICENSE
%{_bindir}/celery*
%changelog