File python-ironicclient.spec of Package python-ironicclient
#
# spec file for package python-ironicclient
#
# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%global sname python-ironicclient
Name: python-ironicclient
Version: 1.11.1
Release: 0
Summary: Python API and CLI for OpenStack Ironic
License: Apache-2.0
Group: Development/Languages/Python
Url: https://launchpad.net/%{sname}
Source0: https://pypi.io/packages/source/p/%{sname}/%{sname}-%{version}.tar.gz
BuildRequires: openstack-macros
BuildRequires: python-Babel >= 2.3.4
BuildRequires: python-PrettyTable >= 0.7.1
BuildRequires: python-PyYAML >= 3.10.0
BuildRequires: python-appdirs >= 1.3.0
BuildRequires: python-devel
BuildRequires: python-dogpile.cache >= 0.6.2
BuildRequires: python-fixtures >= 3.0.0
BuildRequires: python-jsonschema >= 2.0.0
BuildRequires: python-mock >= 2.0
BuildRequires: python-openstackclient >= 3.3.0
BuildRequires: python-os-testr >= 0.8.0
BuildRequires: python-osc-lib >= 1.2.0
BuildRequires: python-oslo.i18n >= 2.1.0
BuildRequires: python-oslo.utils >= 3.18.0
BuildRequires: python-oslotest >= 1.10.0
BuildRequires: python-pbr >= 1.8
BuildRequires: python-python-subunit >= 0.0.18
BuildRequires: python-requests >= 2.10.0
BuildRequires: python-requests-mock >= 1.1
BuildRequires: python-testtools >= 1.4.0
Requires: python-PrettyTable >= 0.7.1
Requires: python-PyYAML >= 3.10.0
Requires: python-appdirs >= 1.3.0
Requires: python-dogpile.cache >= 0.6.2
Requires: python-jsonschema >= 2.0.0
Requires: python-keystoneauth1 >= 2.18.0
Requires: python-openstackclient >= 3.3.0
Requires: python-osc-lib >= 1.2.0
Requires: python-oslo.i18n >= 2.1.0
Requires: python-oslo.utils >= 3.18.0
Requires: python-pbr >= 1.8
Requires: python-requests >= 2.10.0
Requires: python-six >= 1.9.0
BuildArch: noarch
%description
OpenStack Bare Metal Provisioning API Client Library
This is a client for the OpenStack Ironic API. It provides a Python API (the
ironicclient module) and a command-line interface (ironic).
%package doc
Summary: Documentation for OpenStack Ironic API Client
Group: Documentation
BuildRequires: python-Sphinx
BuildRequires: python-oslosphinx >= 4.7.0
BuildRequires: python-reno >= 1.8.0
%description doc
This is a client for the OpenStack Ironic API (Bare Metal. There's a
Python API (the ironicclient module), and a command-line script (ironic).
Each implements 100% of the OpenStack Ironic API.
This package contains auto-generated documentation.
%prep
%autosetup -n %{sname}-%{version}
%py_req_cleanup
%build
%{py2_build}
%{__python2} setup.py build_sphinx
# remove the sphinx-build leftovers
rm -rf doc/build/html/.{doctrees,buildinfo}
%install
%{py2_install}
# bash completion
install -p -D -m 644 tools/ironic.bash_completion %{buildroot}%{_sysconfdir}/bash_completion.d/ironic.bash_completion
%check
%{__python2} setup.py testr
%files
%license LICENSE
%doc README.rst
%{_bindir}/ironic
%{python2_sitelib}/ironicclient
%{python2_sitelib}/*.egg-info
%{_bindir}/ironic
%{_sysconfdir}/bash_completion.d/ironic.bash_completion
%files doc
%license LICENSE
%doc doc/build/html
%changelog