File python-testtools.spec of Package python-testtools

#
# spec file for package python-testtools
#
# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


# A build cycle exists between python-extras and python-testtools. Thus, only
# enable testing with a build conditional (off by default):
%bcond_with tests 

Name:           python-testtools
Version:        1.5.0
Release:        0
Summary:        Extensions to the Python Standard Library Unit Testing Framework
License:        MIT
Group:          Development/Languages/Python
Url:            https://launchpad.net/testtools
Source:         https://pypi.python.org/packages/source/t/testtools/testtools-%{version}.tar.gz
BuildRequires:  python-devel
BuildRequires:  python-extras
BuildRequires:  python-python-mimeparse
BuildRequires:  python-unittest2 >= 0.8.0
# Documentation requirements:
BuildRequires:  python-Sphinx
Requires:       python-extras
Requires:       python-python-mimeparse
Requires:       python-unittest2 >= 0.8.0
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
%if 0%{?suse_version} && 0%{?suse_version} <= 1110
%{!?python_sitelib: %global python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
%else
BuildArch:      noarch
%endif

%description
testtools is a set of extensions to the Python standard library's unit tests
framework. These extensions have been derived from many years of experience
with unit tests in Python and come from many different sources. testtools
also ports recent unittest changes all the way back to Python 2.4.

%prep
%setup -q -n testtools-%{version}

%build
python setup.py build
python setup.py build_sphinx
# Remove unwanted hidden file
rm build/sphinx/html/.buildinfo

%install
python setup.py install --prefix=%{_prefix} --root=%{buildroot}

%if %{with tests}
%check
python setup.py test
%endif

%files
%defattr(-,root,root,-)
%doc LICENSE NEWS README.rst build/sphinx/html
%{python_sitelib}/testtools
%{python_sitelib}/testtools-%{version}-py%{py_ver}.egg-info

%changelog
openSUSE Build Service is sponsored by