File python3-gevent.spec of Package python3-gevent
#
# spec file for package python3-gevent
#
# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: python3-gevent
Version: 1.1.2
Release: 0
Summary: Python network library that uses greenlet and libevent
License: MIT
Group: Development/Languages/Python
Url: http://www.gevent.org/
Source: https://files.pythonhosted.org/packages/source/g/gevent/gevent-%{version}.tar.gz
BuildRequires: libcares-devel
BuildRequires: libev-devel
#BuildRequires: python-Sphinx
BuildRequires: python3-devel
BuildRequires: python3-greenlet
BuildRequires: python3-nose
Requires: python3-greenlet
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%description
Gevent is a Python networking library that uses greenlet to provide synchronous
API on top of a libevent event loop. Features include:
* Fast event loop based on libevent.
* Lightweight execution units based on greenlet.
* Familiar API that re-uses concepts from the Python standard library.
* Cooperative sockets with ssl support.
* DNS queries performed through libevent-dns.
* Ability to use standard library and 3rd party modules written for standard
blocking sockets
* Fast WSGI server based on libevent-http.
gevent is inspired by eventlet but features more consistent API, simpler
implementation and better performance. Read why others use gevent and check
out the list of the open source projects based on gevent.
%prep
%setup -q -n gevent-%{version}
# Remove bundled libraries
rm -rf c-ares libev
%build
CFLAGS="%{optflags} -fno-strict-aliasing" python3 setup.py build
#cd doc && make html && rm _build/html/.buildinfo # Build HTML documentation
%install
python3 setup.py install --prefix=%{_prefix} --root=%{buildroot}
%check
nosetests
%files
%defattr(-,root,root,-)
%doc AUTHORS changelog.rst LICENSE* README.rst TODO examples
#%%doc doc/_build/html
%{python3_sitearch}/*
%changelog