File python3-tox.spec of Package python3-tox

#
# spec file for package python3-tox
#
# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           python3-tox
Version:        2.3.1
Release:        0
Summary:        Virtualenv-based automation of test activities
License:        MIT
Group:          Development/Languages/Python
Url:            https://bitbucket.org/hpk42/tox
Source:         https://files.pythonhosted.org/packages/source/t/tox/tox-%{version}.tar.gz
# PATCH-FIX-OPENSUSE speilicke@suse.com -- Due to update-alternative usage, some bianries aren't available at build-time
Patch0:         tox-disable-env-tests.patch
BuildRequires:  python3-devel
BuildRequires:  unzip
BuildRequires:  python3-pluggy
BuildRequires:  python3-py >= 1.4.17
BuildRequires:  python3-virtualenv >= 1.11.2
Requires:       python3-pluggy
Requires:       python3-py >= 1.4.17
Requires:       python3-virtualenv >= 1.11.2
Requires(post): update-alternatives
Requires(postun): update-alternatives
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildArch:      noarch

%description
Tox as is a generic virtualenv management and test command line tool you can
use for:

* checking your package installs correctly with different
  Python versions and interpreters

* running your tests in each of the
  environments, configuring your test tool of choice

* acting as a frontend to Continuous Integration
  servers, greatly reducing boilerplate and merging
  CI and shell-based testing.

%prep
%setup -q -n tox-%{version}
%patch0 -p1
sed -i -e "/^\\[testenv\\]/ a\\sitepackages = True" tox.ini
sed -i -e "s/tox=tox:cmdline/tox-%{py3_ver}=tox:cmdline/" \
       -e "s/tox-quickstart=tox._quickstart:main/tox-quickstart-%{py3_ver}=tox._quickstart:main/" setup.py

%build
python3 setup.py build

%install
python3 setup.py install --prefix=%{_prefix} --root=%{buildroot}
mkdir -p %{buildroot}%{_sysconfdir}/alternatives
for B in tox tox-quickstart ; do
  touch %{buildroot}%{_sysconfdir}/alternatives/$B
  ln -sf %{_sysconfdir}/alternatives/$B %{buildroot}/%{_bindir}/$B
done

%post
update-alternatives \
    --install %{_bindir}/tox tox %{_bindir}/tox-%{py3_ver} 30 \
    --slave %{_bindir}/tox-quickstart tox-quickstart %{_bindir}/tox-quickstart-%{py3_ver}

%postun
if [ $1 -eq 0 ] ; then
    update-alternatives --remove tox %{_bindir}/tox-%{py3_ver}
fi

%files
%defattr(-,root,root,-)
%doc LICENSE README.rst
%{_bindir}/tox
%{_bindir}/tox-%{py3_ver}
%ghost %{_sysconfdir}/alternatives/tox
%{_bindir}/tox-quickstart
%{_bindir}/tox-quickstart-%{py3_ver}
%ghost %{_sysconfdir}/alternatives/tox-quickstart
%{python3_sitelib}/tox-%{version}-py%{py3_ver}.egg-info
%{python3_sitelib}/tox

%changelog
openSUSE Build Service is sponsored by