File qscintilla.spec of Package qscintilla
#
# spec file for package qscintilla
#
# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%define sonum 12
%define debug_package_requires libqscintilla2-%{sonum} = %{version}-%{release}
Name: qscintilla
Version: 2.9
Release: 0
Summary: C++ Editor Class Library
License: GPL-3.0
Group: Development/Libraries/C and C++
Url: http://www.riverbankcomputing.co.uk/software/qscintilla/intro
Source: http://downloads.sourceforge.net/project/pyqt/QScintilla2/QScintilla-%{version}/QScintilla-gpl-%{version}.tar.gz
Patch0: %{name}.diff
BuildRequires: libdrm-devel
BuildRequires: libqt4-devel
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%description
QScintilla is a Qt port of Neil Hodgson's Scintilla C++ editor class.
This is a Qt port from the original Scintilla class
(http://www.scintilla.org/).
This package is mainly used by eric, the Python IDE.
%package -n libqscintilla2-%{sonum}
Summary: C++ Editor Class Library
Group: Development/Libraries/C and C++
Provides: qscintilla = %{version}
%description -n libqscintilla2-%{sonum}
QScintilla is a Qt port of Neil Hodgson's Scintilla C++ editor class.
This is a Qt port from the original Scintilla class
(http://www.scintilla.org/).
This package is mainly used by eric, the Python IDE.
%package -n libqscintilla-devel
Summary: C++ Editor Class Library Development Files
Group: Development/Libraries/C and C++
Requires: libqscintilla2-%{sonum} = %{version}
# openSUSE 10.3
Provides: qscintilla-devel = %{version}
Obsoletes: qscintilla-devel < %{version}
%requires_ge libqt4-devel
%description -n libqscintilla-devel
QScintilla is a Qt port of Neil Hodgson's Scintilla C++ editor class.
This is a Qt port from the original Scintilla class
(http://www.scintilla.org/).
This package is mainly used by eric, the Python IDE.
%prep
%setup -q -n QScintilla-gpl-%{version}
%patch0
%build
pushd Qt4Qt5
qmake
make %{?_smp_mflags}
popd
pushd designer-Qt4Qt5
qmake
make %{?_smp_mflags}
popd
%install
pushd Qt4Qt5
make INSTALL_ROOT=%{buildroot} install
popd
pushd designer-Qt4Qt5
make INSTALL_ROOT=%{buildroot} install
popd
%post -n libqscintilla2-%{sonum} -p /sbin/ldconfig
%postun -n libqscintilla2-%{sonum} -p /sbin/ldconfig
%files -n libqscintilla2-%{sonum}
%defattr(-,root,root)
%doc NEWS README LICENSE
%{_datadir}/qt4/qsci
%{_datadir}/qt4/translations/qscintilla_*.qm
%{_libdir}/libqscintilla2.so.%{sonum}*
%files -n libqscintilla-devel
%defattr(-,root,root)
%{_includedir}/Qsci
%{_includedir}/Qsci/*
%{_libdir}/libqscintilla2.so
%{_libdir}/qt4/plugins/designer/libqscintillaplugin.so
%{_datadir}/qt4/mkspecs/features/qscintilla2.prf
%changelog