File fence-agents.spec of Package fence-agents.openSUSE_Leap_42.3_Update

#
# spec file for package fence-agents
#
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%global plugin_dir %{_libdir}/stonith/plugins/rhcs

Name:           fence-agents
Summary:        Fence Agents for Pacemaker from RHCS
License:        GPL-2.0-only AND LGPL-2.1-only
Group:          Productivity/Clustering/HA
Version:        4.0.25+git.1485179354.eb43835
Release:        0
Url:            https://github.com/ClusterLabs/fence-agents
Source0:        %{name}-%{version}.tar.xz
Patch1:         0001-fence_compute-Only-list-nova-compute-services-when-g.patch
Patch2:         0002-fence_compute-Don-t-list-hypervisors-but-nova-comput.patch
Patch3:         0003-fence_compute-Do-not-override-domain-if-it-is-alread.patch
Patch4:         0004-fence_compute-Fix-handling-of-domain-None.patch
Patch5:         0005-fence_compute-Fix-fix_domain-to-not-return-too-early.patch
Patch6:         0006-fence_compute-Fix-fix_plug_name-when-looking-if-plug.patch
Patch7:         0007-fence_compute-Remove-duplicate-check-for-binary-name.patch
Patch8:         0008-fence_compute-fix-to-avoid-breaking-nova.patch
# PATCH-FIX-UPSTREAM: fence_evacaute: Add evacuate agent (bsc#1097260)
Patch9:         0009-Compute-Handle-differences-in-Nova-API-argument-pass.patch
Patch10:        0010-Compute-Split-out-evacation-functionality.patch
Patch11:        0011-evacuate-Handle-changes-to-the-nova-API.patch
Patch12:        0012-compute-Fix-unfencing-and-ensure-fencing-occurs-in-p.patch
Patch13:        0013-compute-update-metadata.patch
Patch14:        0014-evacuate-add-expected-metadata.patch
Patch15:        0015-fencing-Add-consistency-between-command-line-and-STD.patch
Patch16:        0016-fix-for-ignored-options.patch
Patch17:        0017-Maintain-ABI-compatibility-for-external-agents.patch
# PATCH-FIX-UPSTREAM: fencing: include timestamps when logging to STDERR and debug file (bsc#1049852)
Patch18:        0018-fencing-include-timestamps-when-logging-to-STDERR-an.patch
Patch19:        0019-fencing-fix-help-for-quiet.patch
Patch20:        0020-compute-Add-support-for-keystone-v3-authentication.patch
Patch21:        0021-fence_compute-evacuate-update-metadata.patch
Patch22:        0022-Log-the-proper-nova_versions-variable.patch
Patch23:        0023-move-fence_evacuate-into-its-own-subdirectory.patch
Patch24:        0024-fence_compute-fence_evacuate-revert-to-old-parameter.patch

# PATCH-FIX-SLE: Make pywsman dependency optional (bsc#1025149)
Patch100:       0100-Make-pywsman-dependency-optional.patch

BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildRequires:  autoconf
BuildRequires:  automake
BuildRequires:  fdupes
BuildRequires:  glibc-devel
BuildRequires:  libtool
BuildRequires:  libxml2-tools
BuildRequires:  libxslt
BuildRequires:  mozilla-nspr-devel
BuildRequires:  mozilla-nss-devel
BuildRequires:  perl
BuildRequires:  perl-Net-Telnet
BuildRequires:  pkg-config
BuildRequires:  python
BuildRequires:  python-curl
BuildRequires:  python-pexpect
BuildRequires:  python-requests
BuildRequires:  python-suds
BuildRequires:  python-xml
BuildRequires:  xz

Requires:       net-snmp
Requires:       openssh
Requires:       perl-Net-Telnet
Requires:       python-curl
Requires:       python-openssl
Requires:       python-pexpect
Requires:       python-requests
Requires:       python-suds
Requires:       sg3_utils
Requires:       telnet

# This is required by fence_virsh. Per discussion on fedora-devel
# switching from package to file based require.
Recommends:     /usr/bin/virsh

# This is required by fence_ipmilan. it appears that the packages
# have changed Requires around. Make sure to get the right one.
Recommends:     /usr/bin/ipmitool

Recommends:     openwsman-python

%if 0%{?with_regression_tests}
BuildRequires:  time
%endif

%description
Fence Agents is a collection of scripts to handle remote power
management for several devices.

%package devel
Summary:        Fence Agents for Pacemaker from RHCS
Group:          Development/Tools/Other
Requires:       %{name} = %{version}

%description devel
Fence Agents is a collection of scripts to handle remote power
management for several devices. This package contains
fence agents only suitable for development.

%prep
%setup -q -n %{name}-%{version}
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
%patch5 -p1
%patch6 -p1
%patch7 -p1
%patch8 -p1
%patch9 -p1
%patch10 -p1
%patch11 -p1
%patch12 -p1
%patch13 -p1
%patch14 -p1
%patch15 -p1
%patch16 -p1
%patch17 -p1
%patch18 -p1
%patch19 -p1
%patch20 -p1
%patch21 -p1
%patch22 -p1
%patch23 -p1
%patch24 -p1

%patch100 -p1

%build
CFLAGS="${CFLAGS} ${RPM_OPT_FLAGS}"
export CFLAGS
./autogen.sh
%{configure}
make

%install
make install DESTDIR=%{buildroot}

## tree fix up
# fix libfence permissions
chmod 0755 %{buildroot}%{_datadir}/fence/fenc*.py
# remove docs
rm -rf %{buildroot}/usr/share/doc/fence-agents
# create links to agents in the plugins dir
mkdir -p %{buildroot}%{plugin_dir}
ln -s %{_sbindir}/fence_cisco_ucs %{buildroot}%{plugin_dir}
%fdupes %buildroot%{_sbindir}
%fdupes %buildroot%{_datadir}/cluster

%if 0%{?with_regression_tests}
%check
make check
PYTHONPATH=fence/agents/lib python fence/agents/lib/tests/test_fencing.py
%endif

%files
%defattr(-,root,root,-)
%doc doc/COPYING.* doc/COPYRIGHT doc/README.licence
%dir %{plugin_dir}
%dir %{_libdir}/stonith/plugins
%dir %{_libdir}/stonith
%{_datadir}/fence
%{_datadir}/cluster
%{plugin_dir}/fence_cisco_ucs
%{_sbindir}/fence_*
%exclude %{_sbindir}/fence_dummy
%exclude %{_mandir}/man8/fence_dummy*
%{_mandir}/man8/fence_*
%{_libexecdir}/fence_*

%files devel
%{_sbindir}/fence_dummy
%{_mandir}/man8/fence_dummy*

%changelog
openSUSE Build Service is sponsored by