File at.spec of Package at.openSUSE_Leap_42.3_Update

#
# spec file for package at
#
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           at
Version:        3.1.14
Release:        0
Summary:        A Job Manager
License:        GPL-2.0-or-later
Group:          System/Daemons

Url:            ftp://ftp.debian.org/debian/pool/main/a/at
Source:         ftp://ftp.debian.org/debian/pool/main/a/at/%{name}_%{version}.orig.tar.gz
Source2:        atd.pamd
Source3:        sysconfig.atd
Source4:        at.sleep
Source5:        atd.service

Patch0:         at-3.1.14.patch
Patch4:         at-3.1.14-joblist.patch
Patch5:         at-3.1.14-selinux.patch
Patch7:         at-3.1.8-eal3-manpages.patch
## no bugs anymore for patch8. Just paranoia checking
Patch8:         at-3.1.13-formatbugs.patch
Patch9:         at-3.1.13-pam.patch
Patch10:        at-3.1.13-massive_batch.patch
Patch11:        at-3.1.13-documentation-dir.patch
Patch12:        at-3.1.13-queue-nice-level.patch
# PATCH-FIX-UPSTREAM pam-session-as-root (bnc#408986, bnc#239210)
Patch14:        at-3.1.13-pam-session-as-root.patch
# PATCH-FIX-UPSTREAM clean-up opened descriptors (bnc#533454, bnc#523346)
Patch15:        at-3.1.13-leak-fix.patch
#PATCH-FIX-OPENSUSE add proper system users to the deny list
Patch16:        at-3.1.8-denylist.patch
#PATCH-FIX-UPSTREAM plan jobs with past time to tomorrow (bnc#672586)
Patch17:        at-3.1.13-tomorrow.patch
#PATCH-FIX-UPSTREAM wrong mtime handling of jobdir (bnc#680113)
Patch19:        at-3.1.8-jobdir-mtime.patch
Patch20:        at-3.1.14-parse-suse-sysconfig.patch
#PATCH-FIX-UPSTREAM fix makefile dependencies
Patch21:        at-3.1.14-makefile-deps.patch
#PATCH-FIX-OPENSUSE Set pid dir to /run not /var/run
Patch22:        at-piddir.patch
Patch23:        at-secure_getenv.patch
#PATCH-FIX-OPENSUSE backport privs from 3.1.8 (bnc#849720)
Patch24:        at-backport-old-privs.patch
#PATCH-FIX-UPSTREAM sanitize environment variables (bnc#899160)
Patch25:        at-3.1.14-sane-envkeys.patch
# PATCH-FIX-UPSTREAM bnc#945124 kstreitova@suse.com -- don't loop on corrupt files and prevent their creation
Patch26:        at-3.1.14-handle_malformed_jobs.patch
Patch27:        at-atq-timeformat.patch

BuildRequires:  autoconf >= 2.69
BuildRequires:  automake
BuildRequires:  bison
BuildRequires:  flex
BuildRequires:  libselinux-devel
BuildRequires:  pam-devel
%if 0%{?suse_version} > 1140
BuildRequires:  libHX-devel
BuildRequires:  pkgconfig
BuildRequires:  pkgconfig(systemd)
%{?systemd_requires}
%define has_systemd 1
%endif
BuildRoot:      %{_tmppath}/%{name}-%{version}-build

PreReq:         %{_sbindir}/useradd %{_sbindir}/groupadd %fillup_prereq %insserv_prereq
PreReq:         permissions
Recommends:     smtp_daemon

%description
This program allows you to run jobs at specified times.

%prep
%setup -q
%patch0
%patch4
%patch5
%patch7
%patch8
%patch9
%patch10
%patch11
%patch12
%patch14
%patch15
%patch16
%patch17 -p1
%patch19
%patch20 -p1
%patch21 -p1
%patch22
%patch23 -p1
%patch24 -p1
%patch25 -p1
%patch26 -p1
%patch27

%build
rm -fv y.tab.c y.tab.h lex.yy.c lex.yy.o y.tab.o
autoreconf -fiv

export CFLAGS="%{?optflags} -fPIE"
export LDFLAGS="-pie"
export SENDMAIL=%{_sbindir}/sendmail

%configure \
  --with-pam \
  --with-selinux \
  --with-daemon_username=at \
  --with-daemon_groupname=at

%{__make} %{?_smp_mflags}

%install
%{__install} -d %{buildroot}{%{_sysconfdir}/pam.d,%{_bindir},%{_sbindir},%{_mandir}/man{1,5,8},%{_localstatedir}/adm/fillup-templates}

export CFLAGS="%{?optflags}"
export SENDMAIL=%{_sbindir}/sendmail

%{__make} install IROOT=%{buildroot}

# Don't install docs here in this way
mkdir docs
mv %{buildroot}/%{_prefix}/doc/at/* docs/

%{__install} -D -m 0644 %{S:5} %{buildroot}%{_unitdir}/atd.service
%{__install} -D -m 0755 %{S:4} %{buildroot}%{_prefix}/lib/systemd/system-sleep/atd.sh
%{__ln_s} -f ../../%{_sbindir}/service %{buildroot}%{_sbindir}/rcatd

%{__install} -m644 %SOURCE2 %{buildroot}%{_sysconfdir}/pam.d/atd
%{__install} -m644 %SOURCE3 %{buildroot}%{_localstatedir}/adm/fillup-templates

%pre
%{_sbindir}/groupadd -g 25 -o -r at 2> /dev/null || :
%{_sbindir}/useradd -r -o -g at -u 25 -s /bin/bash -c "Batch jobs daemon" -d /var/spool/atjobs at 2> /dev/null || :
%service_add_pre atd.service

%preun
%stop_on_removal atd
%service_del_preun atd.service

%post
# update hack
# the rcscript used to be /etc/init.d/at
if [ -f etc/init.d/at ] ; then
  rm -f etc/init.d/at
  %{insserv_cleanup}
fi
%set_permissions /usr/bin/at
%service_add_post atd.service

%verifyscript
%verify_permissions -e /usr/bin/at

%postun
%insserv_cleanup
%service_del_postun atd.service

%files
%defattr(-,root,root)
%doc Problems Copyright COPYING README ChangeLog timespec
%config(noreplace) %{_sysconfdir}/at.deny
%{_sbindir}/rcatd
%config %attr(644,root,root) %{_sysconfdir}/pam.d/atd
%verify(not mode) %attr(4750,root,trusted) %{_bindir}/at
%{_bindir}/atq
%{_bindir}/atrm
%{_bindir}/batch
%{_mandir}/man?/*
%{_sbindir}/atd
%{_sbindir}/atrun
%attr(700,at,at) %dir %{_localstatedir}/spool/atspool
%attr(1770,at,at) %dir %{_localstatedir}/spool/atjobs
%attr(600,at,at) %{_localstatedir}/spool/atjobs/.SEQ
%{_localstatedir}/adm/fillup-templates/sysconfig.atd
%{_unitdir}/atd.service
%{_prefix}/lib/systemd/system-sleep/atd.sh

%changelog
openSUSE Build Service is sponsored by