File skelcd-sles.spec of Package skelcd-sles

#
# spec file for package skelcd-sles
#
# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

%define PRODUCT_PATH_REL_NOTES SUSE_Linux_Enterprise_Server_15
%define PRODUCT SLES
%define product sles

# release is a beta
%define beta 0

%if 0%{?beta} == 1
%define license_dir license.beta
%else
%define license_dir license.final
%endif

# SLE15 uses different paths
%if 0%{?suse_version} > 1320
%define skelcd1_path usr/lib/skelcd/CD1
%else
%define skelcd1_path CD1
%endif

Name:           skelcd-%{product}
BuildRequires:  release-notes-%{product}
BuildRequires:  suse-build-key
AutoReqProv:    off
Version:        2019.07.05
Release:        0
Summary:        CD skeleton
License:        GPL-2.0-only
Group:          Metapackages
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
Source:         skelcd.tar.bz2
Source2:        README
Source3:        README.BETA
Source4:        README.manual
# please repo-checker (bsc#1089174)
Provides:	skelcd = %{version}
Conflicts:	otherproviders(skelcd)

%description
Internal package only.

%package -n skelcd-EULA-%{product}
Summary:        EULA for media
Group:          Metapackages

%description -n skelcd-EULA-%{product}
Internal package only.

%package -n skelcd-EULA-%{PRODUCT}_BCL
Summary:        EULA for media
Group:          Metapackages

%description -n skelcd-EULA-%{PRODUCT}_BCL
Internal package only.

%prep
%setup -n skelcd -q

%build

%install
mkdir -p $RPM_BUILD_ROOT/%{skelcd1_path}/boot
cp READMEs/* $RPM_BUILD_ROOT/%{skelcd1_path}/
cp /usr/lib/rpm/gnupg/keys/* $RPM_BUILD_ROOT/%{skelcd1_path}/
for i in README \
%if %{?beta} == 1
        README.BETA \
%endif
        ; do
  cp -pv $RPM_SOURCE_DIR/$i $RPM_BUILD_ROOT/%{skelcd1_path}/$i
done
## The new way to do it...
mkdir -p $RPM_BUILD_ROOT/%{skelcd1_path}/media.1
pushd %license_dir
ls -1 > directory.yast # required for downloading of EULAs from SCC
tar cvzf license-%{PRODUCT}.tar.gz --owner=root --group=root *txt directory.yast
cp license-%{PRODUCT}.tar.gz $RPM_BUILD_ROOT/%{skelcd1_path}/
popd

# workaround for BCL
# Checked with Ciaran - since BCL does not introduce own code, SLES EULA will be fine
cp %license_dir/license-%{PRODUCT}.tar.gz $RPM_BUILD_ROOT/%{skelcd1_path}/license-%{PRODUCT}_BCL.tar.gz 

#
# Install PDF documentation
#
mkdir -p $RPM_BUILD_ROOT/%{skelcd1_path}/docu/
for i in ar cs de en es fr hu it ja ko pl pt_BR ru zh_CN zh_TW ; do
  test -f "/usr/share/doc/manual/%{product}-installquick_$i-pdf/*.pdf" || continue;
  mkdir -p $RPM_BUILD_ROOT/%{skelcd1_path}/docu/$i
  for book in admin deployment installquick storage; do
    pdf="/usr/share/doc/manual/%{product}-${book}_$i-pdf/*.pdf"
    test -f $pdf && \
      cp -av $pdf $RPM_BUILD_ROOT/%{skelcd1_path}/docu/$i/${book}.pdf
  done
  # remove empty directories
  rmdir $RPM_BUILD_ROOT/%{skelcd1_path}/docu/$i ||:
done
# XXX install $RPM_SOURCE_DIR/README.manual $RPM_BUILD_ROOT/%{skelcd1_path}/docu/
#
# Install release notes as HTML pages
#
cp -vp /usr/share/doc/release-notes/%{PRODUCT_PATH_REL_NOTES}/RELEASE-NOTES.en.* \
	 $RPM_BUILD_ROOT/%{skelcd1_path}/docu/

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(644,root,root,755)
%exclude /%{skelcd1_path}/license-*.tar.gz
%dir /usr/lib/skelcd/
/%{skelcd1_path}

%files -n skelcd-EULA-%{product}
%defattr(644,root,root,755)
/%{skelcd1_path}/license-%{PRODUCT}.tar.gz

%files -n skelcd-EULA-%{PRODUCT}_BCL
%defattr(644,root,root,755)
/%{skelcd1_path}/license-%{PRODUCT}_BCL.tar.gz


%changelog
openSUSE Build Service is sponsored by