File SLED-release.spec of Package 000release-packages
#
# spec file for package SLED
#
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
# old location was /etc/YaST2/licenses/, see jsc#SLE-3067
%define product_license_dir /usr/share/licenses/product/
%define betaversion RC2
Name: sled-release
Summary: SUSE Linux Enterprise Desktop 15 SP3 RC2
License: MIT
Group: System/Fhs
Version: 15.3
Release: 0
BuildRequires: skelcd-EULA-sled
Recommends: branding
# in rare cases, 'ln' is not found...
Requires(post): coreutils
Recommends: issue-generator
# bsc#1078737#c7
Recommends: release-notes-sled
Provides: distribution-release
Provides: product(SUSE_SLE) = %{version}-%{release}
Provides: product(SUSE_SLE-SP3) = %{version}-%{release}
# used by yast to show where the product will be shown during installation.
# lowest number will be top-most
Provides: displayorder(500)
# bsc#1055299
Conflicts: otherproviders(distribution-release)
# bsc#1049164
Obsoletes: leanos-release
#bsc#1071720
Obsoletes: sled-release-DVD < 15
Obsoletes: sled-release-MINI < 15
Obsoletes: sled-release-POOL < 15
Provides: %name-%version
Provides: product() = SLED
Provides: product(SLED) = 15.3-0
%ifarch x86_64
Provides: product-register-target() = sle%2D15%2Dx86_64
%endif
Provides: product-label() = SLED15%2DSP3
Provides: product-cpeid() = cpe%3A%2Fo%3Asuse%3Asled%3A15%3Asp3
Provides: product-url(releasenotes) = https%3A%2F%2Fwww.suse.com%2Freleasenotes%2F%{_target_cpu}%2FSUSE%2DSLED%2F15%2DSP3%2Frelease%2Dnotes%2Dsled.rpm
%ifarch x86_64
Provides: product-updates-repoid() = obsrepository%3A%2F%2Fbuild.suse.de%2FSUSE%3AUpdates%3ASLE%2DProduct%2DSLED%3A15%2DSP3%3Ax86_64%2Fupdate
%endif
%ifarch x86_64
Provides: product-updates-repoid() = obsrepository%3A%2F%2Fbuild.suse.de%2FSUSE%3AUpdates%3ASLE%2DProduct%2DSLED%3A15%2DSP3%3Ax86_64%2Fupdate_debug
%endif
Provides: product-endoflife()
Provides: product(SLED-SP3) = %version-%release
Obsoletes: SLED-SP3-migration
Obsoletes: product:SLED-SP3-migration
Provides: product(SUSE_SLE) = 15.3
Provides: product(SUSE_SLE-SP3) = 15.3
# Make sure we are at SLE15 level
# TBD
PreReq: glibc >= 2.22
Conflicts: kernel < 4.4
Conflicts: perl-Bootloader < 0.904
# old package obsoletes removed
# ./.
BuildRoot: %{_tmppath}/%{name}-%{version}-build
# this package should only be available for the "basearchs" of a product
# i586 added as installation-images-SLES reequires it.
ExclusiveArch: i586 x86_64
Source100: weakremovers.inc
%include %{SOURCE100}
%description
SUSE Linux Enterprise offers a comprehensive
suite of products built on a single code base.
The platform addresses business needs from
the smallest thin-client devices to the world's
most powerful high-performance computing
and mainframe servers. SUSE Linux Enterprise
offers common management tools and technology
certifications across the platform, and
each product is enterprise-class. SUSE Linux
Enterprise provides more than a cute desktop
product or a basic server offering. It is the
only Linux platform for enterprise computing,
and it is now replacing UNIX* and Windows*
as well.
%prep
%build
%install
mkdir -p $RPM_BUILD_ROOT/etc
mkdir -p $RPM_BUILD_ROOT/usr/lib/issue.d
# Create set-up for issue-generator
echo -e "\nWelcome to SUSE Linux Enterprise Desktop 15 SP3 RC2 (%{_target_cpu}) - Kernel \\\r (\\\l).\n" > $RPM_BUILD_ROOT/usr/lib/issue.d/10-SUSE
echo -e "\n" > $RPM_BUILD_ROOT/usr/lib/issue.d/90-SUSE
# create /etc/SuSE-release - deprecated, FATE#316268
# no longer build, in case you wonder
touch $RPM_BUILD_ROOT/etc/motd
# Setup rpm macros
mkdir -p $RPM_BUILD_ROOT/etc/rpm/
echo "#" > $RPM_BUILD_ROOT/etc/rpm/macros.sle
echo "# RPM macros to identify SLE distribution" >> $RPM_BUILD_ROOT/etc/rpm/macros.sle
echo "#" >> $RPM_BUILD_ROOT/etc/rpm/macros.sle
echo "#==================================================" >> $RPM_BUILD_ROOT/etc/rpm/macros.sle
echo "" >> $RPM_BUILD_ROOT/etc/rpm/macros.sle
echo "%%sle_version %sle_version" >> $RPM_BUILD_ROOT/etc/rpm/macros.sle
# Put EULA into correct place [FATE#324053]
mkdir -p $RPM_BUILD_ROOT/%{product_license_dir}/SLED
cd $RPM_BUILD_ROOT/%{product_license_dir}/SLED
tar -xf /usr/lib/skelcd/CD1/license-SLED.tar.gz # --overwrite
echo "directory.yast" > directory.yast
ls lic* > directory.yast
mkdir -p $RPM_BUILD_ROOT/etc
cat >$RPM_BUILD_ROOT/etc/os-release << EOF
NAME="SLED"
VERSION="15-SP3%{?betaversion: }%{?betaversion}"
VERSION_ID="%{version}"
PRETTY_NAME="SUSE Linux Enterprise Desktop 15 SP3%{?betaversion: (}%{?betaversion}%{?betaversion:)}"
ID="sled"
ID_LIKE="suse"
ANSI_COLOR="0;32"
CPE_NAME="cpe:/o:suse:sled:15:sp3"
EOF
cat << EOF >> $RPM_BUILD_ROOT/etc/os-release
DOCUMENTATION_URL="https://documentation.suse.com/"
EOF
mkdir -p $RPM_BUILD_ROOT/etc/products.d
cat >$RPM_BUILD_ROOT/etc/products.d/SLED.prod << EOF
<?xml version="1.0" encoding="UTF-8"?>
<product schemeversion="0">
<vendor>SUSE</vendor>
<name>SLED</name>
<version>15.3</version>
<baseversion>15</baseversion>
<patchlevel>3</patchlevel>
<release>0</release>
<endoflife></endoflife>
<arch>%{_target_cpu}</arch>
<cpeid>cpe:/o:suse:sled:15:sp3</cpeid>
<productline>sled</productline>
<codestream>
<name>SUSE Linux Enterprise Desktop 15</name>
<endoflife>2028-07-31</endoflife>
</codestream>
<register>
%ifarch x86_64
<target>sle-15-x86_64</target>
%endif
</register>
<repositories>
%ifarch x86_64
<repository type="update" repoid="obsrepository://build.suse.de/SUSE:Updates:SLE-Product-SLED:15-SP3:x86_64/update" />
%endif
%ifarch x86_64
<repository type="update" repoid="obsrepository://build.suse.de/SUSE:Updates:SLE-Product-SLED:15-SP3:x86_64/update_debug" />
%endif
%ifarch x86_64
<repository type="pool" repoid="obsproduct://build.suse.de/SUSE:Products:SLE-Product-SLED:15-SP3:x86_64/SLED/15.3/%{_target_cpu}" />
%endif
</repositories>
<summary>SUSE Linux Enterprise Desktop 15 SP3</summary>
<shortsummary>SLED15-SP3</shortsummary>
<description>SUSE Linux Enterprise offers a comprehensive
suite of products built on a single code base.
The platform addresses business needs from
the smallest thin-client devices to the world's
most powerful high-performance computing
and mainframe servers. SUSE Linux Enterprise
offers common management tools and technology
certifications across the platform, and
each product is enterprise-class. SUSE Linux
Enterprise provides more than a cute desktop
product or a basic server offering. It is the
only Linux platform for enterprise computing,
and it is now replacing UNIX* and Windows*
as well.</description>
<linguas>
<language>cs</language>
<language>da</language>
<language>de</language>
<language>en</language>
<language>en_GB</language>
<language>en_US</language>
<language>es</language>
<language>fi</language>
<language>fr</language>
<language>hu</language>
<language>it</language>
<language>ja</language>
<language>nb</language>
<language>nl</language>
<language>pl</language>
<language>pt</language>
<language>pt_BR</language>
<language>ru</language>
<language>sv</language>
<language>zh</language>
<language>zh_CN</language>
<language>zh_TW</language>
</linguas>
<urls>
<url name="releasenotes">https://www.suse.com/releasenotes/%{_target_cpu}/SUSE-SLED/15-SP3/release-notes-sled.rpm</url>
</urls>
<buildconfig>
<producttheme>SLED</producttheme>
<betaversion>RC2</betaversion>
</buildconfig>
<installconfig>
<defaultlang>en_US</defaultlang>
<releasepackage name="%{name}" flag="EQ" version="%{version}" release="%{release}"/>
<distribution>SUSE_SLE</distribution>
</installconfig>
<runtimeconfig/>
<productdependency relationship="provides" name="SUSE_SLE" baseversion="15" patchlevel="3" flag="EQ"/>
<productdependency relationship="provides" name="SUSE_SLE-SP3" baseversion="15" patchlevel="3" flag="EQ"/>
</product>
EOF
%post
if [ -L /etc/products.d/baseproduct ] ; then
PRODLINK=`readlink -f /etc/products.d/baseproduct`
PRODLINK=`basename $PRODLINK`
if [ $PRODLINK == "SUSE_SLED.prod" -o $PRODLINK == "openSUSE.prod" ]; then
ln -sf SLED.prod /etc/products.d/baseproduct
fi
# bsc#1057321
elif [ ! -e /etc/products.d/baseproduct ]; then
ln -sf SLED.prod /etc/products.d/baseproduct
fi
# TBD: Verify that this is still needed for SLE 15..
# bsc#942519: remove hardcoded default valuex
if [ -f /etc/default/grub ] ; then
sed -i -e 's|GRUB_DISTRIBUTOR=SLES12|GRUB_DISTRIBUTOR=|g' /etc/default/grub ||:
fi
# Put EULA into correct place
if [ ! -e %{product_license_dir}/base ] ; then
ln -sf SLED %{product_license_dir}/base
fi
%files
%defattr(644,root,root,755)
%config /etc/os-release
%dir /etc/products.d
%ghost /etc/products.d/baseproduct
/etc/products.d/*
%config /etc/rpm/macros.sle
%config(noreplace) /etc/motd
%dir %{product_license_dir}
%dir %{product_license_dir}SLED/
%dir /usr/lib/issue.d/
/usr/lib/issue.d/*-SUSE
%license %{product_license_dir}/SLED/license*txt
%{product_license_dir}/SLED/directory.yast
%changelog