File rubygem-rack-1_3.spec of Package rubygem-rack-1_3

#
# spec file for package rubygem-rack-1_3
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


# norootforbuild
Name:           rubygem-rack-1_3
Version:        1.3.5
Release:        0
%define mod_name rack
%define mod_full_name %{mod_name}-%{version}
%define mod_branch -1_3
%define mod_weight 13
#
Group:          Development/Languages/Ruby
License:        MIT
#
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildRequires:  rubygems_with_buildroot_patch
%rubygems_requires
Provides:       rubygem-%{mod_name}-1 = %{version}-%{release}
Provides:       rubygem-%{mod_name} = %{version}-%{release}
PreReq:         update-alternatives
#
Url:            http://rack.rubyforge.org
Source:         %{mod_full_name}.gem
#
Summary:        A modular Ruby webserver interface
%description
Rack provides minimal, modular and adaptable interface for developing
web applications in Ruby.  By wrapping HTTP requests and responses in
the simplest way possible, it unifies and distills the API for web
servers, web frameworks, and software in between (the so-called
middleware) into a single method call.

Also see http://rack.rubyforge.org.

%package doc
Summary:        RDoc documentation for %{mod_name}
Group:          Development/Languages/Ruby
Requires:       %{name} = %{version}
%description doc
Documentation generated at gem installation time.
Usually in RDoc and RI formats.

%package testsuite
Summary:        Test suite for %{mod_name}
Group:          Development/Languages/Ruby
Requires:       %{name} = %{version}
%description testsuite
Test::Unit or RSpec files, useful for developers.

%prep
%build
%install
%gem_install %{S:0}
mv %{buildroot}%{_bindir}/rackup{,%{mod_branch}}
ln -s rackup %{buildroot}%{_bindir}/rackup
# make sure it installs the right version when using rackup-*
ruby -p -i.bak -e '$_.gsub!(/>= 0/, "= %{version}")' %{buildroot}%{_bindir}/rackup%{mod_branch}
diff -urN %{buildroot}%{_bindir}/rackup%{mod_branch}{.bak,} || :
rm %{buildroot}%{_bindir}/rackup%{mod_branch}.bak

%clean
%{__rm} -rf %{buildroot}

%post
/usr/sbin/update-alternatives --install \
    %{_bindir}/rackup rackup %{_bindir}/rackup%{mod_branch} %{mod_weight}

%preun
if [ "$1" = 0 ] ; then
    /usr/sbin/update-alternatives --remove rackup %{_bindir}/rackup%{mod_branch}
fi

%files
%defattr(-,root,root,-)
%ghost %config(noreplace) %{_bindir}/rackup
%{_bindir}/rackup%{mod_branch}
%{_libdir}/ruby/gems/%{rb_ver}/cache/%{mod_full_name}.gem
%{_libdir}/ruby/gems/%{rb_ver}/gems/%{mod_full_name}/
%exclude %{_libdir}/ruby/gems/%{rb_ver}/gems/%{mod_full_name}/test
%{_libdir}/ruby/gems/%{rb_ver}/specifications/%{mod_full_name}.gemspec

%files doc
%defattr(-,root,root,-)
%doc %{_libdir}/ruby/gems/%{rb_ver}/doc/%{mod_full_name}/

%files testsuite
%defattr(-,root,root,-)
%{_libdir}/ruby/gems/%{rb_ver}/gems/%{mod_full_name}/test

%changelog
openSUSE Build Service is sponsored by