File perl-Rose-DB.spec of Package perl-Rose-DB

#
# spec file for package perl-Rose-DB
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


%define cpan_name Rose-DB
Name:           perl-Rose-DB
Version:        0.786.0
Release:        0
# 0.786 -> normalize -> 0.786.0
%define cpan_version 0.786
License:        Artistic-1.0 OR GPL-1.0-or-later
Summary:        DBI wrapper and abstraction layer
URL:            https://metacpan.org/release/%{cpan_name}
Source0:        https://cpan.metacpan.org/authors/id/J/JS/JSIRACUSA/%{cpan_name}-%{cpan_version}.tar.gz
Source1:        cpanspec.yml
BuildArch:      noarch
BuildRequires:  perl
BuildRequires:  perl-macros
BuildRequires:  perl(Bit::Vector::Overload) >= 6.4
BuildRequires:  perl(Clone::PP)
BuildRequires:  perl(DBI)
BuildRequires:  perl(DateTime::Duration)
BuildRequires:  perl(DateTime::Format::MySQL)
BuildRequires:  perl(DateTime::Format::Oracle)
BuildRequires:  perl(DateTime::Format::Pg) >= 0.11
BuildRequires:  perl(Rose::DateTime::Util) >= 0.532
BuildRequires:  perl(Rose::Object) >= 0.854
BuildRequires:  perl(SQL::ReservedWords)
BuildRequires:  perl(Time::Clock)
Requires:       perl(Bit::Vector::Overload) >= 6.4
Requires:       perl(Clone::PP)
Requires:       perl(DBI)
Requires:       perl(DateTime::Duration)
Requires:       perl(DateTime::Format::MySQL)
Requires:       perl(DateTime::Format::Oracle)
Requires:       perl(DateTime::Format::Pg) >= 0.11
Requires:       perl(Rose::DateTime::Util) >= 0.532
Requires:       perl(Rose::Object) >= 0.854
Requires:       perl(SQL::ReservedWords)
Requires:       perl(Time::Clock)
Provides:       perl(Rose::DB) = %{version}
Provides:       perl(Rose::DB::Cache) = 0.755.0
Provides:       perl(Rose::DB::Cache::Entry) = 0.736.0
Provides:       perl(Rose::DB::Constants)
Provides:       perl(Rose::DB::Generic) = 0.110.0
Provides:       perl(Rose::DB::Informix) = 0.774.0
Provides:       perl(Rose::DB::MariaDB) = 0.780.0
Provides:       perl(Rose::DB::MySQL) = 0.774.0
Provides:       perl(Rose::DB::Oracle) = 0.784.0
Provides:       perl(Rose::DB::Oracle::DateHandler)
Provides:       perl(Rose::DB::Pg) = %{version}
Provides:       perl(Rose::DB::Registry) = 0.728.0
Provides:       perl(Rose::DB::Registry::Entry) = 0.784.0
Provides:       perl(Rose::DB::SQLite) = 0.765.0
Provides:       perl(Rose::DateTime::Format::Generic)
%undefine       __perllib_provides
%{perl_requires}

%description
Rose::DB is a wrapper and abstraction layer for DBI-related functionality.
A Rose::DB object "has a" DBI object; it is not a subclass of DBI.

Please see the tutorial (perldoc Rose::DB::Tutorial) for an example usage
scenario that reflects "best practices" for this module.

*Tip:* Are you looking for an object-relational mapper (ORM)? If so, please
see the Rose::DB::Object module. Rose::DB::Object is an ORM that uses this
module to manage its database connections. Rose::DB alone is simply a data
source abstraction layer; it is not an ORM.

%prep
%autosetup  -n %{cpan_name}-%{cpan_version}

find . -type f ! -path "*/t/*" ! -name "*.pl" ! -path "*/bin/*" ! -path "*/script/*" ! -path "*/scripts/*" ! -name "configure" -print0 | xargs -0 chmod 644

%build
perl Makefile.PL INSTALLDIRS=vendor
%make_build

%check
make test

%install
%perl_make_install
%perl_process_packlist
%perl_gen_filelist

%files -f %{name}.files
%doc Changes

%changelog
openSUSE Build Service is sponsored by