File perl-Unicode-MapUTF8.spec of Package perl-Unicode-MapUTF8
#
# spec file for package perl-Unicode-MapUTF8
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
# norootforbuild
Name: perl-Unicode-MapUTF8
%define cpan_name Unicode-MapUTF8
Summary: Conversions to and from arbitrary character sets and UTF8
Url: http://search.cpan.org/perldoc?Unicode::MapUTF8
Group: Development/Libraries/Perl
License: Artistic License
Version: 1.11
Release: 1
Source: %{cpan_name}-%{version}.tar.gz
BuildRequires: perl-macros
#BuildRequires: perl(Test::Distribution)
BuildRequires: perl(Test::Pod::Coverage)
BuildRequires: perl(Test::Pod)
BuildRequires: perl(Unicode::String)
BuildRequires: perl(Unicode::Map)
BuildRequires: perl(Unicode::Map8)
BuildRequires: perl(Jcode)
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%{perl_requires}
%description
Provides an adapter layer between core routines for converting to and from
UTF8 and other encodings. In essence, a way to give multiple existing
Unicode modules a single common interface so you don't have to know the
underlaying implementations to do simple UTF8 to-from other character set
encoding conversions. As such, it wraps the Unicode::String, Unicode::Map8,
Unicode::Map and Jcode modules in a standardized and simple API.
This also provides general character set conversion operation based on UTF8
- it is possible to convert between any two compatible and supported
character sets via a simple two step chaining of conversions.
As with most things Perlish - if you give it a few big chunks of text to
chew on instead of lots of small ones it will handle many more characters
per second.
By design, it can be easily extended to encompass any new charset encoding
conversion modules that arrive on the scene.
This module is intended to provide good Unicode support to versions of Perl
prior to 5.8. If you are using Perl 5.8.0 or later, you probably want to be
using the Encode module instead. This module does work with Perl 5.8, but
Encode is the preferred method in that environment.
Author:
-------
Benjamin Franz <snowhare@nihongo.org>
%prep
%setup -n %{cpan_name}-%{version}
%build
perl Makefile.PL
make %{?jobs:-j%jobs}
%check
make test
%install
%perl_make_install
%perl_process_packlist
%perl_gen_filelist
%clean
rm -rf %{buildroot}
%files -f %{name}.files
%defattr(-, root, root)
%doc Changes README MANIFEST
%changelog