File python-dnspython.spec of Package python-dnspython

#
# spec file for package python-dnspython
#
# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%{?!python_module:%define python_module() python-%{**} python3-%{**}}
Name:           python-dnspython
Version:        1.15.0
Release:        0
Summary:        A DNS toolkit for Python
License:        ISC
Group:          Development/Languages/Python
Url:            http://dnspython.org/
Source:         http://dnspython.org/kits/%{version}/dnspython-%{version}.tar.gz
Source2:        http://dnspython.org/kits/%{version}/dnspython-%{version}.tar.gz.asc
Source3:        python-dnspython.keyring
# PATCH-FIX-UPSTREAM 210.patch git_hub@avram.us -- https://github.com/rthalley/dnspython/pull/210.patch
Patch0:         210.patch
# PATCH-FEATURE-OPENSUSE readme.patch -- Add the readme as patch as not included in the tarball.
Patch1:         readme.patch
BuildRequires:  %{python_module devel}
BuildRequires:  %{python_module ecdsa}
BuildRequires:  %{python_module idna}
BuildRequires:  %{python_module pycrypto}
BuildRequires:  %{python_module setuptools}
BuildRequires:  fdupes
BuildRequires:  netcfg
BuildRequires:  python-rpm-macros
Recommends:     python-ecdsa
Recommends:     python-idna
Recommends:     python-pycrypto
BuildArch:      noarch

%description
dnspython is a DNS toolkit for Python. It supports almost all
record types. It can be used for queries, zone transfers, and
dynamic updates. It supports TSIG authenticated messages and EDNS0.

dnspython provides both high and low level access to DNS. The high
level classes perform queries for data of a given name, type, and
class, and return an answer set. The low level classes allow direct
manipulation of DNS zones, messages, names, and records.

dnspython originated at Nominum where it was developed to
facilitate the testing of DNS software. Nominum has generously
allowed it to be opened under a BSD-style licence.

%python_subpackages

%prep
%setup -q -n dnspython-%{version}
chmod -x examples/*
%patch0
%patch1

%build
%python_build

%install
%python_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}/

%check
# Skip the resolver test suite as it requires Internet connection.
test -f tests/test_resolver.py && rm tests/test_resolver.py
%python_exec setup.py test

%files %{python_files}
%defattr(-,root,root)
%doc ChangeLog LICENSE README.md examples/
%{python_sitelib}/dns/
%{python_sitelib}/dnspython-%{version}-py%{python_version}.egg-info

%changelog
openSUSE Build Service is sponsored by