File python-pymongo.spec of Package python-pymongo

#
# spec file for package python-pymongo
#
# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%bcond_without tests

%{?!python_module:%define python_module() python-%{**} python3-%{**}}
Name:           python-pymongo
Version:        3.4.0
Release:        0
Url:            http://github.com/mongodb/mongo-python-driver
Summary:        Python driver for MongoDB
License:        Apache-2.0
Group:          Development/Languages/Python
Source:         https://files.pythonhosted.org/packages/source/p/pymongo/pymongo-%{version}.tar.gz
# PATCH-FIX-UPSTREAm -- tests_should_pass_without_MongoDB_running.patch -- https://jira.mongodb.org/browse/PYTHON-1216
Patch0:         tests_should_pass_without_MongoDB_running.patch
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildRequires:  fdupes
BuildRequires:  python-rpm-macros
BuildRequires:  %{python_module devel}
BuildRequires:  %{python_module setuptools}
Suggests:       mongodb
%python_subpackages

%description
The PyMongo distribution contains tools for interacting with MongoDB
database from Python.  The bson package is an implementation of
the BSON format for Python. The pymongo package is a native Python
driver for MongoDB. The gridfs package is a gridfs
implementation on top of pymongo.

%prep
%setup -q -n pymongo-%{version}
%patch0 -p1

%build
export CFLAGS="%{optflags}"
%python_build

%install
%python_install

%ifarch %{ix86} x86_64 %{arm} aarch64 ppc64le
%python_expand %fdupes %{buildroot}%{$python_sitearch}
%else
%python_expand %fdupes %{buildroot}%{$python_sitelib}
%endif

%if %{with tests}
%check
%python_exec setup.py test
%endif

%files %{python_files}
%defattr(-,root,root,-)
%doc LICENSE README.rst
%ifarch %{ix86} x86_64 %{arm} aarch64 ppc64le
%{python_sitearch}/*
%else
%{python_sitelib}/*
%endif

%changelog
openSUSE Build Service is sponsored by