File python-oslo.utils.spec of Package python-oslo.utils

#
# spec file for package python-oslo.utils
#
# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


%global sname oslo.utils
Name:           python-oslo.utils
Version:        3.28.4
Release:        0
Summary:        OpenStack Utils Library
License:        Apache-2.0
Group:          Development/Languages/Python
Url:            https://launchpad.net/%{sname}
Source0:        https://pypi.io/packages/source/o/%{sname}/%{sname}-%{version}.tar.gz
BuildRequires:  openstack-macros
BuildRequires:  python-Babel >= 2.3.4
BuildRequires:  python-debtcollector >= 1.2.0
BuildRequires:  python-fixtures >= 3.0.0
BuildRequires:  python-iso8601 >= 0.1.11
BuildRequires:  python-mock >= 2.0
BuildRequires:  python-monotonic >= 0.6
BuildRequires:  python-netaddr >= 0.7.13
BuildRequires:  python-netifaces >= 0.10.4
BuildRequires:  python-oslo.i18n >= 2.1.0
BuildRequires:  python-oslotest >= 1.10.0
BuildRequires:  python-pbr >= 2.0.0
BuildRequires:  python-pyparsing >= 2.1.0
BuildRequires:  python-python-subunit >= 0.0.18
BuildRequires:  python-testrepository >= 0.0.18
BuildRequires:  python-testscenarios >= 0.4
BuildRequires:  python-testtools >= 1.4.0
Requires:       python-debtcollector >= 1.2.0
Requires:       python-iso8601 >= 0.1.11
Requires:       python-monotonic >= 0.6
Requires:       python-netaddr >= 0.7.13
Requires:       python-netifaces >= 0.10.4
Requires:       python-oslo.i18n >= 2.1.0
Requires:       python-pyparsing >= 2.1.0
Requires:       python-pytz >= 2013.6
Requires:       python-six >= 1.9.0
BuildArch:      noarch

%description
The oslo.utils library provides support for common utility type functions,
such as encoding, exception handling, string manipulation, and time handling.

%package doc
Summary:        Documentation for OpenStack utils library
Group:          Development/Languages/Python
BuildRequires:  python-Sphinx
BuildRequires:  python-openstackdocstheme >= 1.16.0

%description doc
Documentation for OpenStack utils library.

%prep
%autosetup -n %{sname}-%{version}
sed -i 's/^warning-is-error.*/warning-is-error = 0/g' setup.cfg
%py_req_cleanup

%build
%{py2_build}

%install
%{py2_install}

# generate html docs
%{__python2} setup.py build_sphinx
# remove the sphinx-build leftovers
rm -rf doc/build/html/.{doctrees,buildinfo}

%check
%{__python2} setup.py test

%files
%license LICENSE
%doc ChangeLog README.rst
%{python2_sitelib}/oslo_utils
%{python2_sitelib}/*.egg-info

%files doc
%doc doc/build/html
%license LICENSE

%changelog
openSUSE Build Service is sponsored by