File python-kubernetes.spec of Package python-kubernetes

#
# spec file for package python-kubernetes
#
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%{?!python_module:%define python_module() python-%{**} python3-%{**}}
Name:           python-kubernetes
Version:        5.0.0
Release:        0
Summary:        Kubernetes python client
License:        Apache-2.0
Group:          Development/Languages/Python
Url:            https://github.com/kubernetes-incubator/client-python
Source:         https://files.pythonhosted.org/packages/source/k/kubernetes/kubernetes-%{version}.tar.gz
BuildRequires:  %{python_module PyYAML}
BuildRequires:  %{python_module certifi}
BuildRequires:  %{python_module devel}
BuildRequires:  %{python_module google-auth}
BuildRequires:  %{python_module mock}
BuildRequires:  %{python_module nose}
BuildRequires:  %{python_module oauth2client}
BuildRequires:  %{python_module python-dateutil}
BuildRequires:  %{python_module requests-oauthlib}
BuildRequires:  %{python_module requests}
BuildRequires:  %{python_module setuptools}
BuildRequires:  %{python_module six}
BuildRequires:  %{python_module urllib3}
BuildRequires:  %{python_module websocket-client}
BuildRequires:  fdupes
BuildRequires:  python-rpm-macros
%ifpython2
BuildRequires:  python2-ipaddress
Requires:       python-ipaddress >= 1.0.17
%endif
Requires:       python-PyYAML >= 3.12
Requires:       python-certifi
Requires:       python-google-auth >= 1.0.1
Requires:       python-oauth2client
Requires:       python-python-dateutil >= 2.5.3
Requires:       python-requests
Requires:       python-requests-oauthlib
Requires:       python-setuptools
Requires:       python-six >= 1.9.0
Requires:       python-urllib3 >= 1.19.1
Requires:       python-websocket-client >= 0.32.0
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildArch:      noarch

%python_subpackages

%description
Python client for kubernetes http://kubernetes.io/

%prep
%setup -q -n kubernetes-%{version}

%build
%python_build

%install
%python_install
%fdupes %{buildroot}%{_prefix}

%check
%python_exec %{_bindir}/nosetests --cover-package=kubernetes.config,kubernetes.watch --cover-tests

%files %{python_files}
%defattr(-,root,root,-)
%{python_sitelib}/*

%changelog
openSUSE Build Service is sponsored by