No build reason found for step:i586

File python-tenacity.spec of Package python-tenacity

#
# spec file for package python-tenacity
#
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


%{?!python_module:%define python_module() python-%{**} python3-%{**}}
%bcond_without  test
Name:           python-tenacity
Version:        4.12.0
Release:        0
Summary:        Retry code until it succeeeds
License:        Apache-2.0
Group:          Development/Languages/Python
Url:            https://github.com/jd/tenacity
Source:         https://files.pythonhosted.org/packages/source/t/tenacity/tenacity-%{version}.tar.gz
BuildRequires:  %{python_module devel}
BuildRequires:  %{python_module monotonic >= 0.6}
BuildRequires:  %{python_module pbr}
BuildRequires:  %{python_module pytest}
BuildRequires:  %{python_module setuptools}
BuildRequires:  %{python_module six >= 1.7.0}
BuildRequires:  fdupes
BuildRequires:  python-futures >= 3.0
BuildRequires:  python-rpm-macros
%if %{with test}
BuildRequires:  %{python_module nose}
BuildRequires:  %{python_module tornado}
%endif
Requires:       python-monotonic >= 0.6
Requires:       python-six >= 1.9.0
Recommends:     python-tornado
%ifpython2
Requires:       python-futures >= 3.0
%endif
BuildArch:      noarch

%python_subpackages

%description
Tenacity is a general-purpose retrying library, written in Python, to simplify
the task of adding retry behavior to just about anything.
It originates from a fork of `Retrying`_
Features
--------
- Generic Decorator API
- Specify stop condition (i.e. limit by number of attempts)
- Specify wait condition (i.e. exponential backoff sleeping between attempts)
- Customize retrying on Exceptions
- Customize retrying on expected returned result

%prep
%setup -q -n tenacity-%{version}

%build
%python_build

%install
%python_install
%python_expand %fdupes -s %{buildroot}%{$python_sitelib}

%if %{with test}
%check
%python_exec setup.py nosetests --ignore-files '.*asyncio.py'
%endif

%files %{python_files}
%defattr(-,root,root,-)
%license LICENSE
%doc ChangeLog README.rst
%{python_sitelib}/*

%changelog
openSUSE Build Service is sponsored by