File saltbundlepy-m2crypto.spec of Package saltbundlepy-m2crypto
#
# spec file for package saltbundlepy-m2crypto
#
# Copyright (c) 2021 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%{?!saltbundlepy_module:%define saltbundlepy_module() saltbundlepy-%{**}}
%define pythons saltbundlepy
Name: saltbundlepy-m2crypto
Version: 0.35.2
Release: 0
Summary: Crypto and SSL toolkit for Python
License: MIT
Group: Development/Languages/Python
Url: https://gitlab.com/m2crypto/m2crypto
Source: https://files.pythonhosted.org/packages/source/M/M2Crypto/M2Crypto-%{version}.tar.gz
Patch0: test_rsa.patch
Patch1: test_ssl.patch
Patch2: test_x509_decodebytes_fix.patch
Patch3: PyObject_GC_UNTRACK_fix.patch
BuildRequires: %{saltbundlepy_module devel}
BuildRequires: %{saltbundlepy_module setuptools}
BuildRequires: %{saltbundlepy_module typing}
BuildRequires: fdupes
BuildRequires: openssl
BuildRequires: openssl-devel
BuildRequires: saltbundlepy-rpm-macros
Requires: saltbundlepy-base
BuildRequires: saltbundle-swig
%python_subpackages
%description
M2Crypto is a crypto and SSL toolkit for Python featuring the following:
RSA, DSA, DH, HMACs, message digests, symmetric ciphers (including
AES). SSL functionality to implement clients and servers. HTTPS
extensions to Python's httplib, urllib, and xmlrpclib. Unforgeable
HMAC'ing AuthCookies for web session management. FTP/TLS client and
server. S/MIME. ZServerSSL: A HTTPS server for Zope. ZSmime: An S/MIME
messenger for Zope.
%package -n %{name}-doc
Summary: Documentation for the Crypto and SSL toolkit for Python
Group: Development/Libraries/Python
Requires: %{name} = %{version}
BuildArch: noarch
%description -n %{name}-doc
M2Crypto is a crypto and SSL toolkit for Python featuring the following:
RSA, DSA, DH, HMACs, message digests, symmetric ciphers (including
AES). SSL functionality to implement clients and servers. HTTPS
extensions to Python's httplib, urllib, and xmlrpclib. Unforgeable
HMAC'ing AuthCookies for web session management. FTP/TLS client and
server. S/MIME. ZServerSSL: A HTTPS server for Zope. ZSmime: An S/MIME
messenger for Zope.
Documentation for the Crypto and SSL toolkit for Python
%prep
%setup -q -n M2Crypto-%{version}
%autopatch -p1
%build
export CFLAGS="%{optflags}"
%python_build
%install
%python_install
%python_expand %fdupes %{buildroot}%{$python_sitearch}
%check
%python_exec setup.py test
%files %{python_files}
%doc CHANGES LICENCE README.rst
%{python_sitearch}/*
%files -n %{name}-doc
%doc doc/*.rst
%changelog