File saltbundlepy-asn1crypto.spec of Package saltbundlepy-asn1crypto
#
# spec file for package saltbundlepy-asn1crypto
#
# Copyright (c) 2021 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%{?!saltbundlepy_module:%define saltbundlepy_module() saltbundlepy-%{**}}
%define pythons saltbundlepy
%bcond_without test
Name: saltbundlepy-asn1crypto
Version: 0.24.0
Release: 0
Summary: ASN.1 parser and serializer for Python
License: MIT
Group: Development/Languages/Python
Url: https://github.com/wbond/asn1crypto
Source: https://files.pythonhosted.org/packages/source/a/asn1crypto/asn1crypto-%{version}.tar.gz
BuildRequires: %{saltbundlepy_module devel}
BuildRequires: %{saltbundlepy_module setuptools}
BuildRequires: saltbundlepy-rpm-macros
Requires: saltbundlepy-base
BuildRoot: %{_tmppath}/%{name}-%{version}-build
BuildArch: noarch
%python_subpackages
%description
ASN.1 parser and serializer with definitions for private keys, public keys,
certificates, CRL, OCSP, CMS, PKCS#3, PKCS#7, PKCS#8, PKCS#12, PKCS#5, X509 and TSP
%prep
%setup -q -n asn1crypto-%{version}
%build
%python_build
%install
%python_install
%files %{python_files}
%defattr(-,root,root,-)
%{python_sitelib}/*
%changelog