File saltbundlepy-pyxattr.spec of Package saltbundlepy-pyxattr
#
# spec file for package saltbundlepy-pyxattr
#
# Copyright (c) 2021 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%{?!saltbundlepy_module:%define saltbundlepy_module() saltbundlepy-%{**}}
%define pythons saltbundlepy
# Disable python bytecompile for all distros
# It's called explicitly in the spec
%global __brp_python_bytecompile %{nil}
%define github_url https://github.com/iustin/%{mod_name}/releases/download
%global mod_name pyxattr
Name: saltbundlepy-pyxattr
Version: 0.7.2
Release: 0
Summary: Filesystem extended attributes for python
License: LGPL-2.1-or-later
Group: Development/Libraries/Python
URL: https://pyxattr.k1024.org/
Source0: %{github_url}/v%{version}/%{mod_name}-%{version}.tar.gz
Source1: %{github_url}/v%{version}/%{mod_name}-%{version}.tar.gz.asc
Source2: https://k1024.org/files/key.asc#/%{name}.keyring
BuildRequires: %{saltbundlepy_module devel}
BuildRequires: %{saltbundlepy_module pytest}
BuildRequires: %{saltbundlepy_module setuptools}
BuildRequires: fdupes
BuildRequires: gcc
%if "%_vendor" == "debbuild"
BuildRequires: libattr1-dev
%else
BuildRequires: libattr-devel
%endif
BuildRequires: saltbundlepy-rpm-macros
%python_subpackages
%description
This is a C extension module for Python which
implements extended attributes manipulation. It is a wrapper on top
of the attr C library - see attr(5).
%prep
%autosetup -n pyxattr-%{version}
%build
%python_build
%check
%pytest_arch tests
%install
%python_install
%python_expand %fdupes %{buildroot}%{$python_sitearch}
%files %{python_files}
%{python_sitearch}/xattr*
%{python_sitearch}/pyxattr-%{version}*-info
%license COPYING
%doc NEWS README.md
%changelog