File saltbundlepy-pycurl.spec of Package saltbundlepy-pycurl
#
# spec file for package saltbundlepy-pycurl
#
# Copyright (c) 2021 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%{?!saltbundlepy_module:%define saltbundlepy_module() saltbundlepy-%{**}}
%define pythons saltbundlepy
%global flavor @BUILD_FLAVOR@%{nil}
%if "%{flavor}" == "test"
%define psuffix -test
%bcond_without test
%else
%define psuffix %{nil}
%bcond_with test
%endif
Name: saltbundlepy-pycurl%{psuffix}
Version: 7.43.0.2
Release: 0
Summary: PycURL -- cURL library module
License: LGPL-2.1-or-later AND MIT
Group: Development/Languages/Python
URL: http://pycurl.sourceforge.net/
Source: https://files.pythonhosted.org/packages/source/p/pycurl/pycurl-%{version}.tar.gz
# PATCH-FIX-OPENSUSE increase_test_timeout.diff -- Increase the timeout in a test so it doesn't fail when obs is overloaded
Patch0: increase_test_timeout.diff
# PATCH-FIX-UPSTREAM handle difference between libssh and libssh2
Patch1: pycurl-libssh.patch
# PATCH-FIX-OPENSUSE python-pycurl-7.43.0-tls-backend.patch -- do not run runtime tests to compare linked libs
Patch2: python-pycurl-7.43.0-tls-backend.patch
Patch3: disable_randomly_failing_tests.patch
BuildRequires: %{saltbundlepy_module devel}
BuildRequires: %{saltbundlepy_module setuptools}
BuildRequires: fdupes
BuildRequires: libcurl-devel >= 7.19.0
BuildRequires: openssl-devel
BuildRequires: saltbundlepy-rpm-macros
%if %{with test}
BuildRequires: %{saltbundlepy_module bottle}
BuildRequires: %{saltbundlepy_module flaky}
BuildRequires: %{saltbundlepy_module nose}
%endif
Requires: saltbundlepy-base
%python_subpackages
%description
This module provides bindings for the cURL library.
%package -n %{name}-doc
Summary: Documentation for python-curl
Group: Development/Libraries/Python
Requires: %{name} = %{version}
Provides: %{python_module pycurl-doc = %{version}}
BuildArch: noarch
%description -n %{name}-doc
This module provides bindings for the cURL library.
This package contains documentation and examples.
%prep
%setup -q -n pycurl-%{version}
%autopatch -p1
%build
export CFLAGS="%{optflags} -fno-strict-aliasing"
export PYCURL_SSL_LIBRARY=openssl
%python_build --with-ssl
%install
export PYCURL_SSL_LIBRARY=openssl
%python_install --with-openssl
rm -rf %{buildroot}%{_datadir}/doc # Remove wrongly installed junk
%{python_expand \
$python -m compileall -d %{$python_sitearch} %{buildroot}%{$python_sitearch}
$python -O -m compileall -d %{$python_sitearch} %{buildroot}%{$python_sitearch}
%fdupes %{buildroot}%{$python_sitearch}
}
%check
%if %{with test}
export LANG=en_US.UTF-8
export PYCURL_SSL_LIBRARY=openssl
# taken from "make test" because we only need to run nosetests,
# not the rest of the mess in the upstream runner
pushd tests/fake-curl/libcurl
rm -f *.so
make %{?_smp_mflags}
popd
# exclude certain tests
test_flags='!online,!occasionally_failing'
if ! pkg-config --variable=supported_features libcurl|grep -qw HTTP2; then
test_flags="$test_flags,\!http2"
fi
if ! pkg-config --variable=supported_protocols libcurl|grep -qw SCP; then
test_flags="$test_flags,\!ssh"
fi
%{python_expand PYTHONPATH=%{buildroot}%{$python_sitearch} \
nosetests-%{$python_bin_suffix} -v --with-flaky -a "$test_flags"
}
rm -rf %{buildroot}%{_libexecdir}/debug %{buildroot}%{_libdir}/python*
%endif # test
%files %{python_files}
%license COPYING-LGPL COPYING-MIT
%doc AUTHORS ChangeLog README.rst
%if ! %{with test}
%{python_sitearch}/*
%endif
%files -n %{name}-doc
%doc examples doc/*.rst
%changelog