File saltbundlepy-pytest.spec of Package saltbundlepy-pytest

#
# spec file for package saltbundlepy-pytest
#
# Copyright (c) 2023 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


%{?!saltbundlepy_module:%define saltbundlepy_module() saltbundlepy-%{**}}
%define pythons saltbundlepy

%global flavor @BUILD_FLAVOR@%{nil}
%if "%{flavor}" == "test"
%define psuffix -%{flavor}
%bcond_without test
ExclusiveArch:  do-not-build
%else
%define psuffix %{nil}
%bcond_with test
%endif

Name:           saltbundlepy-pytest%{psuffix}
Version:        7.4.2
Release:        0
Summary:        Simple powerful testing with Python
License:        MIT
URL:            https://github.com/pytest-dev/pytest
Source:         https://files.pythonhosted.org/packages/source/p/pytest/pytest-%{version}.tar.gz
BuildRequires:  %{saltbundlepy_module base >= 3.10}
BuildRequires:  %{saltbundlepy_module setuptools-scm >= 6}
BuildRequires:  %{saltbundlepy_module setuptools}
BuildRequires:  %{saltbundlepy_module tomli >= 1}
BuildRequires:  fdupes
BuildRequires:  saltbundlepy-rpm-macros >= 20210929
Requires:       saltbundlepy-attrs >= 19.2.0
Requires:       saltbundlepy-exceptiongroup
Requires:       saltbundlepy-iniconfig
Requires:       saltbundlepy-packaging
Requires:       saltbundlepy-pluggy >= 0.12
Requires:       saltbundlepy-setuptools
Requires:       saltbundlepy-tomli >= 1
%if "%_vendor" == "debbuild"
Requires:       update-alternatives
%else
Requires(post): update-alternatives
Requires(postun):update-alternatives
%endif
Obsoletes:      saltbundlepy-pytest-doc
BuildArch:      noarch
%if %{with test}
BuildRequires:  %{saltbundlepy_module Jinja2}
BuildRequires:  %{saltbundlepy_module Twisted}
BuildRequires:  %{saltbundlepy_module attrs >= 19.2.0}
BuildRequires:  %{saltbundlepy_module decorator}
BuildRequires:  %{saltbundlepy_module hypothesis >= 3.56}
# nose is really not REQUIRED, the test suite skips over particular
# tests, when the package is not available.
# BuildRequires:  %%{python_module nose}
BuildRequires:  %{saltbundlepy_module pexpect}
BuildRequires:  %{saltbundlepy_module numpy}
BuildRequires:  %{saltbundlepy_module pygments-pytest}
BuildRequires:  %{saltbundlepy_module pytest >= %{version}}
BuildRequires:  %{saltbundlepy_module pytest-xdist}
BuildRequires:  %{saltbundlepy_module requests}
BuildRequires:  %{saltbundlepy_module xmlschema}
BuildRequires:  lsof
%endif
%python_subpackages

%description
The pytest framework makes it easy to write small tests, yet scales to support
complex functional testing for applications and libraries.

%prep
%autosetup -p1 -n pytest-%{version}
# fix gh#pytest-dev/pytest#7891 still happening for Leap
sed -i '/^\[metadata\]/ a version = %{version}' setup.cfg
# Tests not failing with our current version of packages gh#pytest-dev/pytest#10042
sed -i '/pytest.mark.xfail(reason="#10042")/d' testing/test_debugging.py

%build
%python_build

%install
%if ! %{with test}
%python_install
%python_clone -a %{buildroot}%{_bindir}/pytest
%python_clone -a %{buildroot}%{_bindir}/py.test
%python_expand %fdupes %{buildroot}%{$python_sitelib}
%endif

%check
%if %{with test}
# Disable broken tests with latest setuptools, gh#pytest-dev/pytest#10815
donttest="test_cmdline_python_namespace_package or test_syspath_prepend_with_namespace_packages"
# Don't run pexpect tests to avoid timeout error in OBS when running
# in quemu
%pytest -n auto -m "not uses_pexpect" -k "not ($donttest)"
%endif

%if ! %{with test}

%pre
%python_libalternatives_reset_alternative pytest py.test

%post
%python_install_alternative pytest py.test

%postun
%python_uninstall_alternative pytest

%files %{python_files}
%doc AUTHORS CHANGELOG.rst README.rst
%license LICENSE
%python_alternative %{_bindir}/pytest
%python_alternative %{_bindir}/py.test
%pycache_only %{python_sitelib}/__pycache__/*.pyc
%{python_sitelib}/_pytest
%{python_sitelib}/py.py
%{python_sitelib}/pytest
%{python_sitelib}/pytest-%{version}*-info
%endif

%changelog
openSUSE Build Service is sponsored by