File saltbundlepy-paramiko.spec of Package saltbundlepy-paramiko

#
# spec file for package saltbundlepy-paramiko
#
# Copyright (c) 2023 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


%{?!saltbundlepy_module:%define saltbundlepy_module() saltbundlepy-%{**}}
%define pythons saltbundlepy

# Disable python bytecompile for all distros
# It's called explicitly in the spec
%global __brp_python_bytecompile %{nil}

%bcond_with test

Name:           saltbundlepy-paramiko
Version:        2.4.3
Release:        0
Summary:        SSH2 protocol library
License:        LGPL-2.1-or-later
Group:          Development/Languages/Python
URL:            https://www.paramiko.org/
Source:         https://files.pythonhosted.org/packages/source/p/paramiko/paramiko-%{version}.tar.gz
# certificates needed by testsuite
Source1:        cert_support.tar.gz
Patch0:         paramiko-test_extend_timeout.patch
Patch1:         disable-gssapi.patch
Patch2:         add-support-for-new-OpenSSH-private-key-format.patch
Patch3:         paramiko-fix-1169489.patch
Patch4:         support-cryptography-25-and-above.patch
Patch5:         CVE-2022-24302-race-condition.patch
# PATCH-FIX-UPSTREAM rsa-key-loading-fix.patch bsc#1205132 mcepl@suse.com
# p and q were being swapped
Patch6:         rsa-key-loading-fix.patch

BuildRequires:  %{saltbundlepy_module base >= 3.10}
BuildRequires:  %{saltbundlepy_module bcrypt >= 3.1.3}
BuildRequires:  %{saltbundlepy_module cryptography >= 2.5}
BuildRequires:  %{saltbundlepy_module pyasn1 >= 0.1.7}
BuildRequires:  %{saltbundlepy_module pynacl >= 1.0.1}
BuildRequires:  %{saltbundlepy_module setuptools}
BuildRequires:  fdupes
BuildRequires:  saltbundlepy-rpm-macros
Requires:       saltbundlepy-bcrypt >= 3.1.3
Requires:       saltbundlepy-cryptography >= 2.5
Requires:       saltbundlepy-pyasn1 >= 0.1.7
Requires:       saltbundlepy-pynacl >= 1.0.1
BuildArch:      noarch
%if %{with test}
BuildRequires:  %{saltbundlepy_module mock}
BuildRequires:  %{saltbundlepy_module pytest-relaxed}
BuildRequires:  %{saltbundlepy_module pytest}
%endif
%python_subpackages

%description
This is a library for making SSH2 connections (client or server).
Emphasis is on using SSH2 as an alternative to SSL for making secure
connections between python scripts.  All major ciphers and hash methods
are supported.  SFTP client and server mode are both supported too.

%package -n saltbundlepy-paramiko-doc
Summary:        Documentation for %{name}
Group:          Documentation/Other
Provides:       %{saltbundlepy_module paramiko-doc = %{version}}

%description -n saltbundlepy-paramiko-doc
This is a library for making SSH2 connections (client or server).
Emphasis is on using SSH2 as an alternative to SSL for making secure
connections between python scripts.  All major ciphers and hash methods
are supported.  SFTP client and server mode are both supported too.

This package contains the documentation.

%prep
%setup -q -n paramiko-%{version}
%autopatch -p1

# Fix non-executable script rpmlint issue:
find demos -name "*.py" -exec sed -i "/#\!\/usr\/bin\/.*/d" {} \;
tar xvzf %{SOURCE1} -C tests/

%build
%python_build

%install
%python_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}

%if %{with test}
%check
export LANG=en_US.UTF-8
%python_expand pytest-%{$python_bin_suffix}
%endif

%files %{python_files}
%license LICENSE
%doc README.rst
%{python_sitelib}/*

%files -n saltbundlepy-paramiko-doc
%license LICENSE
%doc demos/

%changelog
openSUSE Build Service is sponsored by