File saltbundlepy-importlib-metadata.spec of Package saltbundlepy-importlib-metadata

#
# spec file for package saltbundlepy-importlib-metadata
#
# Copyright (c) 2023 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


%{?!saltbundlepy_module:%define saltbundlepy_module() saltbundlepy-%{**}}
%define pythons saltbundlepy

# Disable python bytecompile for all distros
# It's called explicitly in the spec
%global __brp_python_bytecompile %{nil}

%global flavor @BUILD_FLAVOR@%{nil}
%if "%{flavor}" == "test"
%define psuffix -test
%bcond_without test
%else
%define psuffix %{nil}
%bcond_with test
%endif
Name:           saltbundlepy-importlib-metadata%{psuffix}
Version:        6.8.0
Release:        0
Summary:        Tool to read metadata from Python packages
License:        Apache-2.0
URL:            https://gitlab.com/python-devs/importlib_metadata
Source:         https://files.pythonhosted.org/packages/source/i/importlib_metadata/importlib_metadata-%{version}.tar.gz
BuildRequires:  %{saltbundlepy_module base >= 3.10}
BuildRequires:  %{saltbundlepy_module pip}
BuildRequires:  %{saltbundlepy_module setuptools-scm}
BuildRequires:  %{saltbundlepy_module setuptools}
BuildRequires:  %{saltbundlepy_module tomli}
BuildRequires:  %{saltbundlepy_module wheel}
BuildRequires:  %{saltbundlepy_module zipp >= 0.5}
BuildRequires:  fdupes
BuildRequires:  saltbundlepy-rpm-macros
Requires:       saltbundlepy-zipp >= 0.5
BuildArch:      noarch
%if %{with test}
BuildRequires:  %{saltbundlepy_module packaging}
BuildRequires:  %{saltbundlepy_module pip}
BuildRequires:  %{saltbundlepy_module pyfakefs}
BuildRequires:  %{saltbundlepy_module wheel}
BuildRequires:  %{saltbundlepy_module zipp >= 0.5}
%endif
%python_subpackages

%description
This package supplies third-party access to the functionality of
importlib.metadata including improvements added to subsequent Python versions.

%prep
%setup -q -n importlib_metadata-%{version}

%build
%pyproject_wheel

%install
%if !%{with test}
%pyproject_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}
%endif

%check
%if %{with test}
# no pytest_perf available
%pytest --ignore exercises.py
%endif

%if !%{with test}
%files %{python_files}
%doc README.rst
%license LICENSE
%{python_sitelib}/importlib_metadata
%{python_sitelib}/importlib_metadata-%{version}*-info
%endif

%changelog
openSUSE Build Service is sponsored by