File saltbundlepy-zipp.spec of Package saltbundlepy-zipp
#
# spec file for package saltbundlepy-zipp
#
# Copyright (c) 2025 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%{?!saltbundlepy_module:%define saltbundlepy_module() saltbundlepy-%{**}}
%define pythons saltbundlepy
%global flavor @BUILD_FLAVOR@%{nil}
%if "%{flavor}" == "test"
%define psuffix -test
%bcond_without test
%else
%define psuffix %{nil}
%bcond_with test
%endif
Name: saltbundlepy-zipp%{psuffix}
Version: 3.17.0
Release: 0
Summary: Pathlib-compatible object wrapper for zip files
License: MIT
Group: Development/Languages/Python
URL: https://github.com/jaraco/zipp
Source: https://files.pythonhosted.org/packages/source/z/zipp/zipp-%{version}.tar.gz
# PATCH-FIX-UPSTREAM CVE-2024-5569.patch gh#jaraco/zipp@fd604bd34f03
Patch1: CVE-2024-5569.patch
BuildRequires: %{saltbundlepy_module base >= 3.10}
BuildRequires: %{saltbundlepy_module pip}
BuildRequires: %{saltbundlepy_module setuptools-scm >= 3.4.1}
BuildRequires: %{saltbundlepy_module setuptools}
BuildRequires: %{saltbundlepy_module wheel}
BuildRequires: fdupes
BuildRequires: saltbundlepy-rpm-macros
BuildArch: noarch
%if %{with test}
BuildRequires: %{saltbundlepy_module more-itertools}
BuildRequires: %{saltbundlepy_module pytest >= 3.5}
%endif
Requires: saltbundlepy-more-itertools
%python_subpackages
%description
A pathlib-compatible Zipfile object wrapper.
%prep
%autosetup -p1 -n zipp-%{version}
sed -i '/addopts/ s/--doctest-modules//' pytest.ini
# People still want this for 15.X despite Python 3.6 is not supported upstream anymore
sed -i 's/python_requires = >=3.7/python_requires = >=3.6/' setup.cfg
rm -r zipp.egg-info
%build
%pyproject_wheel
%install
%if !%{with test}
%pyproject_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}
%endif
%if %{with test}
%check
# skip performance test (we do not have func_timeout sofar)
sed -i -e 's:import func_timeout::' \
-e 's:@func_timeout.func_set_timeout(.):@unittest.skip("skip performance test"):' \
tests/test_zipp.py
%pytest
%endif
%if !%{with test}
%files %{python_files}
%doc README.rst
%license LICENSE
%{python_sitelib}/zipp
%{python_sitelib}/zipp-%{version}*-info
%endif
%changelog