File saltbundlepy-py.spec of Package saltbundlepy-py

#
# spec file for package saltbundlepy-py
#
# Copyright (c) 2023 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


%{?!saltbundlepy_module:%define saltbundlepy_module() saltbundlepy-%{**}}
%define pythons saltbundlepy

# Disable python bytecompile for all distros
# It's called explicitly in the spec
%global __brp_python_bytecompile %{nil}

%global flavor @BUILD_FLAVOR@%{nil}
%if "%{flavor}" == "test"
%define psuffix -test
%bcond_without test
%else
%define psuffix %{nil}
%bcond_with test
%endif

Name:           saltbundlepy-py%{psuffix}
Version:        1.11.0
Release:        0
Summary:        Library with cross-python path, ini-parsing, io, code, log facilities
License:        MIT
Group:          Development/Languages/Python
URL:            https://github.com/pytest-dev/py
Source:         https://files.pythonhosted.org/packages/source/p/py/py-%{version}.tar.gz
# https://github.com/pytest-dev/py/pull/222
Patch0:         pr_222.patch
# CVE-2022-42969 Remove all traces of svn
Patch1:         remove-svn-remants.patch
BuildRequires:  %{saltbundlepy_module base >= 3.10}
BuildRequires:  %{saltbundlepy_module setuptools-scm}
BuildRequires:  %{saltbundlepy_module setuptools}
BuildRequires:  fdupes
BuildRequires:  saltbundlepy-rpm-macros
BuildArch:      noarch
%if %{with test}
BuildRequires:  %{saltbundlepy_module pytest}
%endif
Requires:       saltbundlepy-base
%python_subpackages

%description
The py lib is a Python development support library featuring
the following tools and modules:

* py.path:  uniform local and svn path objects
* py.apipkg:  explicit API control and lazy-importing
* py.iniconfig:  easy parsing of .ini files
* py.code: dynamic code generation and introspection
* py.path:  uniform local and svn path objects

%prep
%setup -q -n py-%{version}
%autopatch -p1

rm -rf py.egg-info
rm -f tox.ini
# https://github.com/pytest-dev/py/issues/162
rm -f testing/log/test_warning.py

# CVE-2022-42969 Remove all traces of svn
pushd py/_path
rm svnwc.py svnurl.py
popd
pushd testing/path
rm conftest.py svntestbase.py test_svnauth.py test_svnurl.py test_svnwc.py
popd

%build
%python_build

%install
%if !%{with test}
%python_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}
%endif

%check
%if %{with test}
export LANG=en_US.UTF-8
# In addition to PR 222, there are other tests failing due to changes in pytest 5 & 6
# https://github.com/pytest-dev/py/issues/209
%pytest || :
%endif

%if !%{with test}
%files %{python_files}
%doc README.rst
%license LICENSE
%{python_sitelib}/*
%endif

%changelog
openSUSE Build Service is sponsored by