File saltbundlepy-hatchling.spec of Package saltbundlepy-hatchling

#
# spec file for package saltbundlepy-hatchling
#
# Copyright (c) 2023 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


%{?!saltbundlepy_module:%define saltbundlepy_module() saltbundlepy-%{**}}
%define pythons saltbundlepy

Name:           saltbundlepy-hatchling
Version:        1.13.0
Release:        0
Summary:        Build backend used by Hatch
License:        MIT
URL:            https://hatch.pypa.io/latest/
Source0:        https://files.pythonhosted.org/packages/source/h/hatchling/hatchling-%{version}.tar.gz
BuildRequires:  %{saltbundlepy_module base >= 3.7}
BuildRequires:  %{saltbundlepy_module editables >= 0.3}
BuildRequires:  %{saltbundlepy_module packaging >= 21.3}
BuildRequires:  %{saltbundlepy_module pathspec >= 0.10.1}
BuildRequires:  %{saltbundlepy_module pip}
BuildRequires:  %{saltbundlepy_module pluggy >= 1.0.0}
BuildRequires:  %{saltbundlepy_module tomli >= 1.2.2}
BuildRequires:  fdupes
BuildRequires:  saltbundlepy-rpm-macros
Requires:       saltbundlepy-editables >= 0.3
Requires:       saltbundlepy-packaging >= 21.3
Requires:       saltbundlepy-pathspec >= 0.10.1
Requires:       saltbundlepy-pluggy >= 1.0.0
Requires(post): update-alternatives
Requires(postun):update-alternatives
BuildArch:      noarch
Requires:       saltbundlepy-tomli >= 1.2.2
%python_subpackages

%description
This is the extensible, standards compliant build backend used by Hatch.

%prep
%autosetup -n hatchling-%{version} -p1

%build
%pyproject_wheel

%install
%pyproject_install
%{python_expand \
find %{buildroot}%{$python_sitelib} -name '*.pyc' -delete
$python -m compileall -d %{$python_sitelib} %{buildroot}%{$python_sitelib}
$python -O -m compileall -d %{$python_sitelib} %{buildroot}%{$python_sitelib}
%fdupes %{buildroot}%{$python_sitelib}
}
%python_clone -a %{buildroot}%{_bindir}/hatchling

%check
# The tests provided in the tarball relies on internet access to run
# (git clone, pip install ...), so they cannot work on obs
# see tests/downstream/integrate.py for details

%post
%python_install_alternative hatchling

%postun
%python_uninstall_alternative hatchling

%files %{python_files}
%doc README.md
%license LICENSE.txt
%{python_sitelib}/hatchling
%{python_sitelib}/hatchling-%{version}.dist-info
%python_alternative %{_bindir}/hatchling

%changelog
openSUSE Build Service is sponsored by