File saltbundlepy-msgpack.spec of Package saltbundlepy-msgpack
#
# spec file for package saltbundlepy-msgpack
#
# Copyright (c) 2025 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%{?!saltbundlepy_module:%define saltbundlepy_module() saltbundlepy-%{**}}
%define pythons saltbundlepy
%bcond_without test
Name: saltbundlepy-msgpack
Version: 1.0.7
Release: 0
Summary: MessagePack (de)serializer
License: Apache-2.0
Group: Development/Languages/Python
URL: http://msgpack.org/
Source0: https://files.pythonhosted.org/packages/source/m/msgpack/msgpack-%{version}.tar.gz
Source1: saltbundlepy-msgpack-rpmlintrc
BuildRequires: %{saltbundlepy_module cython}
BuildRequires: %{saltbundlepy_module devel >= 3.10}
BuildRequires: %{saltbundlepy_module setuptools}
BuildRequires: fdupes
BuildRequires: gcc-c++
BuildRequires: saltbundlepy-rpm-macros
%if %{with test}
# Test requirements:
BuildRequires: %{saltbundlepy_module pytest}
%endif
BuildRoot: %{_tmppath}/%{name}-%{version}-build
Requires: saltbundlepy-base
%python_subpackages
%description
MessagePack (de)serializer for Python.
MessagePack is a binary-based efficient data interchange format that is
focused on high performance. It is like JSON, but very fast and small.
%prep
%setup -q -n msgpack-%{version}
%autopatch -p1
%build
export CFLAGS="%{optflags}"
%python_build
%install
%python_install
%python_expand %fdupes %{buildroot}%{$python_sitearch}
%if %{with test}
%check
%{python_expand export PYTHONPATH=%{buildroot}%{$python_sitearch}
py.test-%{$python_bin_suffix}
}
%endif
%files %{python_files}
%defattr(-,root,root,-)
%doc README.md
%license COPYING
%{python_sitearch}/msgpack
%{python_sitearch}/msgpack-%{version}*-info
%changelog