File saltbundlepy-jinja2.spec of Package saltbundlepy-jinja2
#
# spec file for package saltbundlepy-jinja2
#
# Copyright (c) 2025 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%{?!saltbundlepy_module:%define saltbundlepy_module() saltbundlepy-%{**}}
%define pythons saltbundlepy
Name: saltbundlepy-jinja2
Version: 3.1.2
Release: 0
Summary: A template engine written in pure Python
License: BSD-3-Clause
Group: Development/Languages/Python
URL: https://jinja.palletsprojects.com
Source: https://files.pythonhosted.org/packages/source/J/Jinja2/Jinja2-%{version}.tar.gz
# PATCH-FIX-UPSTREAM CVE-2024-34064.patch gh#pallets/jinja@0668239dc6b4
Patch0: CVE-2024-34064.patch
# PATCH-FIX-UPSTREAM CVE-2024-56201.patch
Patch1: CVE-2024-56201.patch
# PATCH-FIX-UPSTREAM CVE-2024-56326.patch
Patch2: CVE-2024-56326.patch
BuildRequires: %{saltbundlepy_module devel >= 3.11}
BuildRequires: %{saltbundlepy_module markupsafe}
BuildRequires: %{saltbundlepy_module setuptools}
BuildRequires: fdupes
BuildRequires: saltbundlepy-rpm-macros
Requires: saltbundlepy-markupsafe >= 0.23
BuildRoot: %{_tmppath}/%{name}-%{version}-build
BuildArch: noarch
%python_subpackages
%description
Jinja2 is a template engine written in pure Python. It provides a Django
inspired non-XML syntax but supports inline expressions and an optional
sandboxed environment.
%prep
%autosetup -p1 -n Jinja2-%{version}
%build
%python_build
%install
%python_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}
%check
%if %{with test}
%pytest -W ignore:'Support for nose tests is deprecated'
%endif
%files %{python_files}
%license LICENSE.rst
%doc README.rst CHANGES.rst artwork examples
%{python_sitelib}/jinja2
%{python_sitelib}/Jinja2-%{version}-py%{python_version}.egg-info
%changelog