File saltbundlepy-pyasn1.spec of Package saltbundlepy-pyasn1

#
# spec file for package saltbundlepy-pyasn1
#
# Copyright (c) 2021 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


%{?!saltbundlepy_module:%define saltbundlepy_module() saltbundlepy-%{**}}
%define pythons saltbundlepy

# Disable python bytecompile for all distros
# It's called explicitly in the spec
%global __brp_python_bytecompile %{nil}

Name:           saltbundlepy-pyasn1
Version:        0.5.0
Release:        0
Summary:        ASN.1 types and codecs
License:        BSD-2-Clause
Group:          Development/Languages/Python
URL:            https://github.com/etingof/pyasn1
Source:         https://pypi.io/packages/source/p/pyasn1/pyasn1-%{version}.tar.gz
BuildRequires:  %{saltbundlepy_module base >= 3.10}
BuildRequires:  %{saltbundlepy_module pip}
BuildRequires:  %{saltbundlepy_module pytest}
BuildRequires:  %{saltbundlepy_module wheel}
BuildRequires:  fdupes
BuildRequires:  saltbundlepy-rpm-macros
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildArch:      noarch
Requires:       saltbundlepy-base
%python_subpackages

%description
This is an implementation of ASN.1 types and codecs in Python programming
language. It has been first written to support particular protocol (SNMP) but
then generalized to be suitable for a wide range of protocols based on ASN.1
specification.

%prep
%setup -q -n pyasn1-%{version}
# Set every __init__.py to have the same mtime bsc#1207805
find . -name __init__.py -exec touch -m -t 201711240800 {} \;

%build
%pyproject_wheel

%install
%pyproject_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}

%check
%pyunittest discover -v

%files %{python_files}
%doc CHANGES.rst README.md TODO.rst
%license LICENSE.rst
%{python_sitelib}/pyasn1
%{python_sitelib}/pyasn1-%{version}.dist-info

%changelog
openSUSE Build Service is sponsored by