File saltbundlepy-zypp-plugin.spec of Package saltbundlepy-zypp-plugin

#
# spec file for package saltbundlepy-zypp-plugin
#
# Copyright (c) 2021 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


%{?!saltbundlepy_module:%define saltbundlepy_module() saltbundlepy-%{**}}
%define pythons saltbundlepy

# Disable python bytecompile for all distros
# It's called explicitly in the spec
%global __brp_python_bytecompile %{nil}

Name:           saltbundlepy-zypp-plugin
Version:        0.6.3
Release:        0
Summary:        Helper that makes writing ZYpp plugins easier
License:        GPL-2.0-only
Group:          System/Packages
URL:            https://github.com/openSUSE/zypp-plugin
Source0:        zypp-plugin-%{version}.tar.bz2
BuildArch:      noarch
BuildRequires:  %{saltbundlepy_module devel >= 3.10}
BuildRequires:  fdupes
BuildRequires:  saltbundlepy-rpm-macros
Requires:       saltbundlepy-base
%python_subpackages

%description
This API allows writing ZYpp plugins by just subclassing from a python class
and implementing the commands you want to respond to as python methods.

%prep
%setup -q -n zypp-plugin

%build
:

%install
%{python_expand mkdir -p %{buildroot}%{python_sitelib}
 install python/zypp_plugin.py %{buildroot}%{$python_sitelib}/zypp_plugin.py
 find %{buildroot}%{$python_sitelib} -name '*.pyc' -delete
 %{__$python} -m compileall -d %{$python_sitelib} %{buildroot}%{$python_sitelib}
 %{__$python} -O -m compileall -d %{$python_sitelib} %{buildroot}%{$python_sitelib}
 %fdupes %{buildroot}%{$python_sitelib}
}

%files %{python_files}
%doc COPYING
%{python_sitelib}/*

%changelog
openSUSE Build Service is sponsored by