File saltbundlepy-flit-core.spec of Package saltbundlepy-flit-core

#
# spec file for saltbundlepy-flit-core
#
# Copyright (c) 2023 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


%{?!saltbundlepy_module:%define saltbundlepy_module() saltbundlepy-%{**}}
%define pythons saltbundlepy

# test everything in the buildset by standard python flavor expansion: primary and non-primary, if any.
%if "%{flavor}" == "test"
%define psuffix -test
%endif

Name:           saltbundlepy-flit-core%{?psuffix}
Version:        3.8.0
Release:        0
Summary:        Distribution-building parts of Flit
License:        BSD-3-Clause AND MIT
URL:            https://github.com/pypa/flit
Source0:        https://files.pythonhosted.org/packages/source/f/flit_core/flit_core-%{version}.tar.gz
BuildRequires:  %{saltbundlepy_module base >= 3.6}
BuildRequires:  fdupes
BuildRequires:  saltbundlepy-rpm-macros
BuildArch:      noarch
%if "%{flavor}" == "test"
BuildRequires:  %{saltbundlepy_module flit-core = %{version}}
BuildRequires:  %{saltbundlepy_module packaging}
BuildRequires:  %{saltbundlepy_module pytest}
BuildRequires:  %{saltbundlepy_module testpath}
%endif
%python_subpackages

%description
This provides a PEP 517 build backend for packages using Flit.
The only public interface is the API specified by PEP 517, at flit_core.buildapi.

%prep
%setup -q -n flit_core-%{version}

%if "%{flavor}" != "test"
%build
%{python_expand \
$python -m flit_core.wheel
}

%install
%{python_expand \
mkdir -p %{buildroot}%{$python_sitelib}
$python bootstrap_install.py dist/flit_core-%{version}-py3-none-any.whl -i %{buildroot}%{$python_sitelib}
# Don't package the tests
rm -r  %{buildroot}%{$python_sitelib}/flit_core/tests
$python -m compileall -d %{$python_sitelib} %{buildroot}%{$python_sitelib}
$python -O -m compileall -d %{$python_sitelib} %{buildroot}%{$python_sitelib}
%fdupes %{buildroot}%{$python_sitelib}
}
%endif

%if "%{flavor}" == "test"
%check
# make sure we do not test the sources but the package
rm flit_core/*.py pyproject.toml
%pytest -rfEs
%endif

%if "%{flavor}" != "test"
%files %{python_files}
%{python_sitelib}/flit_core
%{python_sitelib}/flit_core-%{version}*-info
%endif

%changelog
openSUSE Build Service is sponsored by