File python-cryptography.spec of Package python-cryptography

#
# spec file for package python-cryptography
#
# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%bcond_with tests

%if 0%{?rhel}
%define skip_python3 1
%{?!python_module:%define python_module() python-%{**}}
%else
%{?!python_module:%define python_module() python-%{**} python3-%{**}}
%endif
Name:           python-cryptography
Version:        0.4
Release:        0
Url:            https://cryptography.io/en/latest/
Summary:        Python library which exposes cryptographic recipes and primitives
License:        Apache-2.0
Group:          Development/Languages/Python
Source0:        https://pypi.python.org/packages/source/c/cryptography/cryptography-%{version}.tar.gz
Source1:        https://pypi.python.org/packages/source/c/cryptography/cryptography-%{version}.tar.gz.asc
Source2:        %{name}.keyring
Source3:        https://pypi.python.org/packages/source/c/cryptography/cryptography_vectors-%{version}.tar.gz
Source4:        https://pypi.python.org/packages/source/c/cryptography/cryptography_vectors-%{version}.tar.gz.asc
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
%if 0%{suse_version} && 0%{?suse_version} >= 1220
BuildRequires:  gpg-offline
%endif
BuildRequires:  python-rpm-macros
BuildRequires:  libopenssl-devel
BuildRequires:  %{python_module cffi >= 0.8}
BuildRequires:  %{python_module devel}
BuildRequires:  %{python_module setuptools}
BuildRequires:  %{python_module six >= 1.4.1}
%if %{with tests}
# Test requirements
BuildRequires:  python-iso8601
BuildRequires:  python-pretend
BuildRequires:  python-pyasn1
BuildRequires:  python-pytest
%endif
Requires:       python-cffi >= 0.8
Requires:       python-six >= 1.4.1
BuildRequires:  pkgconfig(libffi)
%python_subpackages

%description
cryptography is a package designed to expose cryptographic
recipes and primitives to Python developers.  Our goal is
for it to be your "cryptographic standard library". It
supports Python 2.6-2.7, Python 3.2+, and PyPy.

cryptography includes both high level recipes, and low
level interfaces to common cryptographic algorithms such as
symmetric ciphers, message digests and key derivation
functions.

%prep
%if 0%{suse_version} && 0%{?suse_version} >= 1220
%gpg_verify %{SOURCE1}
%endif
%setup -q -n cryptography-%{version}

# prepare vectors module
tar xvzf %{S:3}
mv cryptography_vectors-%{version}/cryptography_vectors .

%build
%python_build

%install
%python_install
# do not install cryptography_vectors
%python_expand rm -rf %{buildroot}%{$python_sitearch}/cryptography_vectors

%if %{with tests}
%check
py.test
%endif

%files %{python_files}
%defattr(-,root,root,-)
%doc AUTHORS.rst CONTRIBUTING.rst LICENSE README.rst
%{python_sitearch}/cryptography/
%{python_sitearch}/cryptography-%{version}-py%{py_ver}.egg-info/

%changelog
openSUSE Build Service is sponsored by