LogoopenSUSE Build Service > Projects
Sign Up | Log In

BPF Compiler Collection

BCC is a toolkit for creating efficient kernel tracing and manipulation programs, and includes several useful tools and examples. It makes use of eBPF (Extended Berkeley Packet Filters), a new feature that was first added to Linux 3.15. Much of what BCC uses requires Linux 4.1 and above.

Source Files (show merged sources derived from linked package)

Filename Size Changed Actions
_constraints 394 Bytes Download File
_service 465 Bytes Download File
bcc.changes 29.3 KB Download File
bcc.spec 7.09 KB Download File
v0.0.3.tar.gz 124 KB Download File
v0.10.0.tar.gz 1.96 MB Download File

Comments for Base:System (1)

repo-checker wrote over 1 year ago

The version of this package in openSUSE:Factory has installation issues and may not be installable:

can't install bcc-devel-0.3.0+git1502955391.9de830a-1.1.x86_64:
  package bcc-devel-0.3.0+git1502955391.9de830a-1.1.x86_64 requires libbcc0 = 0.3.0+git1502955391.9de830a, but none of the providers can be installed
  nothing provides libLLVMBPFCodeGen.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMBPFDesc.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMBPFInfo.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMCore.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMSupport.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMX86CodeGen.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMX86Desc.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMX86Info.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMipo.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMExecutionEngine.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMMCJIT.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMRuntimeDyld.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libclangAST.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libclangBasic.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libclangCodeGen.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libclangDriver.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libclangFrontend.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libclangRewrite.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64

can't install bcc-examples-0.3.0+git1502955391.9de830a-1.1.x86_64:
  package bcc-examples-0.3.0+git1502955391.9de830a-1.1.x86_64 requires python-bcc = 0.3.0+git1502955391.9de830a, but none of the providers can be installed
  package python-bcc-0.3.0+git1502955391.9de830a-1.1.x86_64 requires libbcc0 = 0.3.0+git1502955391.9de830a, but none of the providers can be installed
  nothing provides libLLVMBPFCodeGen.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMBPFDesc.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMBPFInfo.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMCore.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMSupport.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMX86CodeGen.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMX86Desc.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMX86Info.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMipo.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMExecutionEngine.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMMCJIT.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMRuntimeDyld.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libclangAST.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libclangBasic.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libclangCodeGen.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libclangDriver.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libclangFrontend.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libclangRewrite.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64

can't install bcc-lua-0.3.0+git1502955391.9de830a-1.1.x86_64:
  nothing provides libLLVMBPFCodeGen.so.4()(64bit) needed by bcc-lua-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMBPFDesc.so.4()(64bit) needed by bcc-lua-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMBPFInfo.so.4()(64bit) needed by bcc-lua-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMCore.so.4()(64bit) needed by bcc-lua-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMSupport.so.4()(64bit) needed by bcc-lua-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMX86CodeGen.so.4()(64bit) needed by bcc-lua-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMX86Desc.so.4()(64bit) needed by bcc-lua-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMX86Info.so.4()(64bit) needed by bcc-lua-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMipo.so.4()(64bit) needed by bcc-lua-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMExecutionEngine.so.4()(64bit) needed by bcc-lua-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMMCJIT.so.4()(64bit) needed by bcc-lua-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMRuntimeDyld.so.4()(64bit) needed by bcc-lua-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libclangAST.so.4()(64bit) needed by bcc-lua-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libclangBasic.so.4()(64bit) needed by bcc-lua-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libclangCodeGen.so.4()(64bit) needed by bcc-lua-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libclangDriver.so.4()(64bit) needed by bcc-lua-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libclangFrontend.so.4()(64bit) needed by bcc-lua-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libclangRewrite.so.4()(64bit) needed by bcc-lua-0.3.0+git1502955391.9de830a-1.1.x86_64

can't install bcc-tools-0.3.0+git1502955391.9de830a-1.1.x86_64:
  package bcc-tools-0.3.0+git1502955391.9de830a-1.1.x86_64 requires python-bcc = 0.3.0+git1502955391.9de830a, but none of the providers can be installed
  package python-bcc-0.3.0+git1502955391.9de830a-1.1.x86_64 requires libbcc0 = 0.3.0+git1502955391.9de830a, but none of the providers can be installed
  nothing provides libLLVMBPFCodeGen.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMBPFDesc.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMBPFInfo.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMCore.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMSupport.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMX86CodeGen.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMX86Desc.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMX86Info.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMipo.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMExecutionEngine.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMMCJIT.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMRuntimeDyld.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libclangAST.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libclangBasic.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libclangCodeGen.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libclangDriver.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libclangFrontend.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libclangRewrite.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64

can't install libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64:
  nothing provides libLLVMBPFCodeGen.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMBPFDesc.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMBPFInfo.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMCore.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMSupport.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMX86CodeGen.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMX86Desc.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMX86Info.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMipo.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMExecutionEngine.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMMCJIT.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMRuntimeDyld.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libclangAST.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libclangBasic.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libclangCodeGen.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libclangDriver.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libclangFrontend.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libclangRewrite.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64

can't install python-bcc-0.3.0+git1502955391.9de830a-1.1.x86_64:
  package python-bcc-0.3.0+git1502955391.9de830a-1.1.x86_64 requires libbcc0 = 0.3.0+git1502955391.9de830a, but none of the providers can be installed
  nothing provides libLLVMBPFCodeGen.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMBPFDesc.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMBPFInfo.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMCore.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMSupport.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMX86CodeGen.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMX86Desc.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMX86Info.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMipo.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMExecutionEngine.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMMCJIT.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMRuntimeDyld.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libclangAST.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libclangBasic.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libclangCodeGen.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libclangDriver.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libclangFrontend.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libclangRewrite.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64

can't install python3-bcc-0.3.0+git1502955391.9de830a-1.1.x86_64:
  package python3-bcc-0.3.0+git1502955391.9de830a-1.1.x86_64 requires libbcc0 = 0.3.0+git1502955391.9de830a, but none of the providers can be installed
  nothing provides libLLVMBPFCodeGen.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMBPFDesc.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMBPFInfo.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMCore.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMSupport.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMX86CodeGen.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMX86Desc.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMX86Info.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMipo.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMExecutionEngine.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMMCJIT.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libLLVMRuntimeDyld.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libclangAST.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libclangBasic.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libclangCodeGen.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libclangDriver.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libclangFrontend.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64
  nothing provides libclangRewrite.so.4()(64bit) needed by libbcc0-0.3.0+git1502955391.9de830a-1.1.x86_64

Login required, please login or signup in order to comment