SIP tool to use python sip bindings

SIP is a tool that makes it very easy to create Python bindings for C
and C++ libraries. It was originally developed to create PyQt, the
Python bindings for the Qt toolkit, but can be used to create bindings
for any C or C++ library.

Refresh
Refresh
Source Files (show merged sources derived from linked package)
Filename Size Changed
Comments for python-sip 4

Eric Schirra's avatar

ecsos wrote 4 months ago

python3-qt5-sip is missing in backports


Benjamin Greiner's avatar

bnavigator wrote 3 months ago

... which should not be used if 0%{suse_version} < 1550. python3-sip4 offers PyQt5.sip built with sip4 for those distros.


Benjamin Greiner's avatar

bnavigator wrote 3 months ago

Many packages are unresolvable because they still see python3-sip-4.19.19 and thus have a BuildRequires conflict. Could you please add Prefer: -python3-sip to the prjconf so that python3-sip4 which offers 4.19.24 wins?


Markéta Machová's avatar

mcalabkova wrote 3 months ago

I hope it is fixed as well.

openSUSE Build Service is sponsored by