Classes to work with KCModules

https://www.kde.org

KCMUtils provides various classes to work with KCModules. KCModules can be
created with the KConfigWidgets framework.

Refresh
Refresh
Source Files
Filename Size Changed Actions
_service 0000000502 502 Bytes about 2 years
baselibs.conf 0000000084 84 Bytes over 5 years
kcmutils.changes 0000025438 24.8 KB 29 days
kcmutils.spec 0000004166 4.07 KB about 1 month
Comments for kcmutils 1

Fabian Vogt's avatar

favogt wrote about 2 months ago

This package has installation issues and may not be installable from the openSUSE_Factory repository:

can't install kcmutils-devel-32bit-5.63.0git.20191012T212118~1036179-ku.2.1.x86_64:
  package kcmutils-devel-32bit-5.63.0git.20191012T212118~1036179-ku.2.1.x86_64 requires libKF5KCMUtils5-32bit = 5.63.0git.20191012T212118~1036179, but none of the providers can be installed
  nothing provides /bin/sh needed by libKF5KCMUtils5-32bit-5.63.0git.20191012T212118~1036179-ku.2.1.x86_64
  nothing provides libc.so.6 needed by libKF5KCMUtils5-32bit-5.63.0git.20191012T212118~1036179-ku.2.1.x86_64
  nothing provides libc.so.6(GLIBC_2.0) needed by libKF5KCMUtils5-32bit-5.63.0git.20191012T212118~1036179-ku.2.1.x86_64
  nothing provides libc.so.6(GLIBC_2.1.3) needed by libKF5KCMUtils5-32bit-5.63.0git.20191012T212118~1036179-ku.2.1.x86_64
  nothing provides libc.so.6(GLIBC_2.4) needed by libKF5KCMUtils5-32bit-5.63.0git.20191012T212118~1036179-ku.2.1.x86_64
  nothing provides libstdc++.so.6 needed by libKF5KCMUtils5-32bit-5.63.0git.20191012T212118~1036179-ku.2.1.x86_64
  nothing provides libstdc++.so.6(CXXABI_1.3) needed by libKF5KCMUtils5-32bit-5.63.0git.20191012T212118~1036179-ku.2.1.x86_64
  nothing provides libstdc++.so.6(GLIBCXX_3.4) needed by libKF5KCMUtils5-32bit-5.63.0git.20191012T212118~1036179-ku.2.1.x86_64

can't install kcmutils-devel-5.63.0git.20191012T212118~1036179-ku.2.1.i586:
  package kcmutils-devel-5.63.0git.20191012T212118~1036179-ku.2.1.i586 requires cmake(KF5ConfigWidgets) >= 5.63, but none of the providers can be installed
  nothing provides libc.so.6 needed by kconfigwidgets-devel-5.63.0git.20191012T212137~e6f115c-ku.3.1.i586
  nothing provides libc.so.6(GLIBC_2.0) needed by kconfigwidgets-devel-5.63.0git.20191012T212137~e6f115c-ku.3.1.i586
  nothing provides libc.so.6(GLIBC_2.1.3) needed by kconfigwidgets-devel-5.63.0git.20191012T212137~e6f115c-ku.3.1.i586
  nothing provides libc.so.6(GLIBC_2.4) needed by kconfigwidgets-devel-5.63.0git.20191012T212137~e6f115c-ku.3.1.i586
  nothing provides libstdc++.so.6 needed by kconfigwidgets-devel-5.63.0git.20191012T212137~e6f115c-ku.3.1.i586
  nothing provides libstdc++.so.6(CXXABI_1.3) needed by kconfigwidgets-devel-5.63.0git.20191012T212137~e6f115c-ku.3.1.i586
  nothing provides libstdc++.so.6(GLIBCXX_3.4) needed by kconfigwidgets-devel-5.63.0git.20191012T212137~e6f115c-ku.3.1.i586
  nothing provides /usr/bin/perl needed by kconfigwidgets-devel-5.63.0git.20191012T212137~e6f115c-ku.3.1.i586

can't install kcmutils-devel-5.63.0git.20191012T212118~1036179-ku.2.1.x86_64:
  package kcmutils-devel-5.63.0git.20191012T212118~1036179-ku.2.1.x86_64 requires libKF5KCMUtils5 = 5.63.0git.20191012T212118~1036179, but none of the providers can be installed
  nothing provides libc.so.6()(64bit) needed by libKF5KCMUtils5-5.63.0git.20191012T212118~1036179-ku.2.1.x86_64
  nothing provides libc.so.6(GLIBC_2.14)(64bit) needed by libKF5KCMUtils5-5.63.0git.20191012T212118~1036179-ku.2.1.x86_64
  nothing provides libc.so.6(GLIBC_2.2.5)(64bit) needed by libKF5KCMUtils5-5.63.0git.20191012T212118~1036179-ku.2.1.x86_64
  nothing provides libc.so.6(GLIBC_2.4)(64bit) needed by libKF5KCMUtils5-5.63.0git.20191012T212118~1036179-ku.2.1.x86_64
  nothing provides libstdc++.so.6()(64bit) needed by libKF5KCMUtils5-5.63.0git.20191012T212118~1036179-ku.2.1.x86_64
  nothing provides libstdc++.so.6(CXXABI_1.3)(64bit) needed by libKF5KCMUtils5-5.63.0git.20191012T212118~1036179-ku.2.1.x86_64
  nothing provides libstdc++.so.6(GLIBCXX_3.4)(64bit) needed by libKF5KCMUtils5-5.63.0git.20191012T212118~1036179-ku.2.1.x86_64
  nothing provides /sbin/ldconfig needed by libKF5KCMUtils5-5.63.0git.20191012T212118~1036179-ku.2.1.x86_64

can't install libKF5KCMUtils5-32bit-5.63.0git.20191012T212118~1036179-ku.2.1.x86_64:
  nothing provides /bin/sh needed by libKF5KCMUtils5-32bit-5.63.0git.20191012T212118~1036179-ku.2.1.x86_64
  nothing provides libc.so.6 needed by libKF5KCMUtils5-32bit-5.63.0git.20191012T212118~1036179-ku.2.1.x86_64
  nothing provides libc.so.6(GLIBC_2.0) needed by libKF5KCMUtils5-32bit-5.63.0git.20191012T212118~1036179-ku.2.1.x86_64
  nothing provides libc.so.6(GLIBC_2.1.3) needed by libKF5KCMUtils5-32bit-5.63.0git.20191012T212118~1036179-ku.2.1.x86_64
  nothing provides libc.so.6(GLIBC_2.4) needed by libKF5KCMUtils5-32bit-5.63.0git.20191012T212118~1036179-ku.2.1.x86_64
  nothing provides libstdc++.so.6 needed by libKF5KCMUtils5-32bit-5.63.0git.20191012T212118~1036179-ku.2.1.x86_64
  nothing provides libstdc++.so.6(CXXABI_1.3) needed by libKF5KCMUtils5-32bit-5.63.0git.20191012T212118~1036179-ku.2.1.x86_64
  nothing provides libstdc++.so.6(GLIBCXX_3.4) needed by libKF5KCMUtils5-32bit-5.63.0git.20191012T212118~1036179-ku.2.1.x86_64

can't install libKF5KCMUtils5-5.63.0git.20191012T212118~1036179-ku.2.1.i586:
  nothing provides libc.so.6 needed by libKF5KCMUtils5-5.63.0git.20191012T212118~1036179-ku.2.1.i586
  nothing provides libc.so.6(GLIBC_2.0) needed by libKF5KCMUtils5-5.63.0git.20191012T212118~1036179-ku.2.1.i586
  nothing provides libc.so.6(GLIBC_2.1.3) needed by libKF5KCMUtils5-5.63.0git.20191012T212118~1036179-ku.2.1.i586
  nothing provides libc.so.6(GLIBC_2.4) needed by libKF5KCMUtils5-5.63.0git.20191012T212118~1036179-ku.2.1.i586
  nothing provides libstdc++.so.6 needed by libKF5KCMUtils5-5.63.0git.20191012T212118~1036179-ku.2.1.i586
  nothing provides libstdc++.so.6(CXXABI_1.3) needed by libKF5KCMUtils5-5.63.0git.20191012T212118~1036179-ku.2.1.i586
  nothing provides libstdc++.so.6(GLIBCXX_3.4) needed by libKF5KCMUtils5-5.63.0git.20191012T212118~1036179-ku.2.1.i586
  nothing provides /sbin/ldconfig needed by libKF5KCMUtils5-5.63.0git.20191012T212118~1036179-ku.2.1.i586

can't install libKF5KCMUtils5-5.63.0git.20191012T212118~1036179-ku.2.1.x86_64:
  nothing provides libc.so.6()(64bit) needed by libKF5KCMUtils5-5.63.0git.20191012T212118~1036179-ku.2.1.x86_64
  nothing provides libc.so.6(GLIBC_2.14)(64bit) needed by libKF5KCMUtils5-5.63.0git.20191012T212118~1036179-ku.2.1.x86_64
  nothing provides libc.so.6(GLIBC_2.2.5)(64bit) needed by libKF5KCMUtils5-5.63.0git.20191012T212118~1036179-ku.2.1.x86_64
  nothing provides libc.so.6(GLIBC_2.4)(64bit) needed by libKF5KCMUtils5-5.63.0git.20191012T212118~1036179-ku.2.1.x86_64
  nothing provides libstdc++.so.6()(64bit) needed by libKF5KCMUtils5-5.63.0git.20191012T212118~1036179-ku.2.1.x86_64
  nothing provides libstdc++.so.6(CXXABI_1.3)(64bit) needed by libKF5KCMUtils5-5.63.0git.20191012T212118~1036179-ku.2.1.x86_64
  nothing provides libstdc++.so.6(GLIBCXX_3.4)(64bit) needed by libKF5KCMUtils5-5.63.0git.20191012T212118~1036179-ku.2.1.x86_64
  nothing provides /sbin/ldconfig needed by libKF5KCMUtils5-5.63.0git.20191012T212118~1036179-ku.2.1.x86_64