A new user interface for you! Read more...

The Objective Caml Compiler and Programming Environment

http://caml.inria.fr/

Objective Caml is a high-level, strongly-typed, functional and
object-oriented programming language from the ML family of languages.

This package comprises two batch compilers (a fast bytecode compiler
and an optimizing native-code compiler), an interactive top level
system, Lex&Yacc tools, a replay debugger, and a comprehensive library.

Refresh
Refresh
Source Files (show merged sources derived from linked package)
Filename Size Changed Actions
ocaml-3.00-camldebug_el.patch 0000000526 526 Bytes over 10 years
ocaml-3.04-ocamltags--no-site-start.patch 0000000487 487 Bytes about 3 years
ocaml-3.08.3-gcc4.patch 0000001776 1.73 KB over 1 year
ocaml-3.09-emacs_localcompile.patch 0000000781 781 Bytes over 1 year
ocaml-4.05.0-CVE-2018-9838.patch 0000002545 2.49 KB about 1 year
ocaml-4.05.0.tar.xz 0002442036 2.33 MB about 2 years
ocaml-configure-Allow-user-defined-C-compiler-flags.patch 0000000509 509 Bytes about 2 years
ocaml-findlib.rpm.prov_req.attr.sh 0000004301 4.2 KB about 3 years
ocaml-fix_aarch64_build.patch 0000319032 312 KB about 1 year
ocaml.changes 0000024138 23.6 KB 3 months
ocaml.spec 0000015238 14.9 KB 3 months
ocamldoc-man-th.patch 0000001963 1.92 KB about 3 years
rpmlintrc 0000000255 255 Bytes over 11 years
Comments for ocaml 1

Repo Checker

repo-checker wrote over 1 year ago

The version of this package in openSUSE:Leap:15.0 has installation issues and may not be installable:

can't install ocaml-4.05.0-lp150.1.19.x86_64:
  package ocaml-4.05.0-lp150.1.19.x86_64 requires gcc, but none of the providers can be installed
  package gcc-7-lp150.1.27.x86_64 requires gcc7, but none of the providers can be installed
  nothing provides libmpfr.so.4()(64bit) needed by gcc7-7.3.0+r257042-lp150.1.3.x86_64

can't install ocaml-docs-4.05.0-lp150.1.19.x86_64:
  package ocaml-4.05.0-lp150.1.19.x86_64 requires gcc, but none of the providers can be installed
  package ocaml-docs-4.05.0-lp150.1.19.x86_64 requires ocaml = 4.05.0, but none of the providers can be installed
  package gcc-7-lp150.1.27.x86_64 requires gcc7, but none of the providers can be installed
  nothing provides libmpfr.so.4()(64bit) needed by gcc7-7.3.0+r257042-lp150.1.3.x86_64

can't install ocaml-emacs-4.05.0-lp150.1.19.x86_64:
  package ocaml-4.05.0-lp150.1.19.x86_64 requires gcc, but none of the providers can be installed
  package ocaml-emacs-4.05.0-lp150.1.19.x86_64 requires ocaml = 4.05.0, but none of the providers can be installed
  package gcc-7-lp150.1.27.x86_64 requires gcc7, but none of the providers can be installed
  nothing provides libmpfr.so.4()(64bit) needed by gcc7-7.3.0+r257042-lp150.1.3.x86_64

can't install ocaml-ocamldoc-4.05.0-lp150.1.19.x86_64:
  package ocaml-4.05.0-lp150.1.19.x86_64 requires gcc, but none of the providers can be installed
  package ocaml-ocamldoc-4.05.0-lp150.1.19.x86_64 requires ocaml = 4.05.0, but none of the providers can be installed
  package gcc-7-lp150.1.27.x86_64 requires gcc7, but none of the providers can be installed
  nothing provides libmpfr.so.4()(64bit) needed by gcc7-7.3.0+r257042-lp150.1.3.x86_64