LogoopenSUSE Build Service > Projects
Sign Up | Log In

An open source reimplementation of the original XCom

OpenXcom is an open-source clone of the original UFO: Enemy Unknown (X-Com: UFO Defense in USA), licensed under the GPL and written in C++ / SDL.

The goal of the project is to bring back the tried and true feel of the original with none of the issues. All the same graphics, sound and gameplay with a brand new codebase written from scratch.

User is required to have original gamedata (possible to obtain from e.g. Steam) installed to ~/.local/share/openxcom/data/

Source Files (show merged sources derived from linked package)

Filename Size Changed Actions
openxcom-1.0.0.tar.gz 2.68 MB Download File
openxcom-abs.patch 1.42 KB Download File
openxcom-math.patch 3.38 KB Download File
openxcom.changes 2.04 KB Download File
openxcom.spec 3.11 KB Download File

Comments for games (2)

repo-checker wrote about 1 year ago

The version of this package in openSUSE:Leap:15.0 has installation issues and may not be installable:

can't install openxcom-1.0.0-lp150.1.3.x86_64:
  nothing provides libyaml-cpp.so.0.5()(64bit) needed by openxcom-1.0.0-lp150.1.3.x86_64

can't install openxcom-doc-1.0.0-lp150.1.3.x86_64:
  package openxcom-doc-1.0.0-lp150.1.3.x86_64 requires openxcom = 1.0.0, but none of the providers can be installed
  nothing provides libyaml-cpp.so.0.5()(64bit) needed by openxcom-1.0.0-lp150.1.3.x86_64
repo-checker wrote about 1 year ago

The version of this package in openSUSE:Factory has installation issues and may not be installable:

can't install openxcom-1.0.0-5.7.i586:
  nothing provides libyaml-cpp.so.0.5 needed by openxcom-1.0.0-5.7.i586

can't install openxcom-1.0.0-5.7.x86_64:
  nothing provides libyaml-cpp.so.0.5()(64bit) needed by openxcom-1.0.0-5.7.x86_64

can't install openxcom-doc-1.0.0-5.7.i586:
  package openxcom-doc-1.0.0-5.7.i586 requires openxcom = 1.0.0, but none of the providers can be installed
  nothing provides libyaml-cpp.so.0.5 needed by openxcom-1.0.0-5.7.i586

can't install openxcom-doc-1.0.0-5.7.x86_64:
  package openxcom-doc-1.0.0-5.7.x86_64 requires openxcom = 1.0.0, but none of the providers can be installed
  nothing provides libyaml-cpp.so.0.5()(64bit) needed by openxcom-1.0.0-5.7.x86_64

Login required, please login or signup in order to comment