Braille display driver for Linux/Unix

http://mielke.cc/brltty/

BRLTTY is a background process (daemon) which provides access to the
Linux/Unix console (when in text mode) for a blind person using a
refreshable braille display. It drives the braille display and provides
complete screen review functionality.

Refresh
Refresh
Source Files (show merged sources derived from linked package)
Filename Size Changed Actions
README.SUSE 0000001489 1.45 KB over 2 years
brltty-5.5-systemd-install.patch 0000000729 729 Bytes 6 months
brltty-6.0.tar.xz 0002879976 2.75 MB 6 months
brltty-alsa.patch 0000000417 417 Bytes 5 months
brltty.changes 0000024366 23.8 KB 2 months
brltty.spec 0000018374 17.9 KB 2 months
Comments for brltty 3

Repo Checker

repo-checker wrote about 2 years ago

The version of this package in openSUSE:Factory has installation issues and may not be installable:

can't install ocaml-brlapi-5.4-6.3.i586:
  package ocaml-brlapi-5.4-6.3.i586 requires ocamlfind(unix), but none of the providers can be installed
  package ocaml-findlib-1.6.2-1.5.i586 requires ocamlfind(num-top), but none of the providers can be installed
  nothing provides ocaml(Array) = 3e56b0036c5d9e653763f3450236560d needed by ocaml-findlib-devel-1.6.2-1.5.i586
    (we have ocaml-runtime-4.05.0-1.1.i586)
  nothing provides ocaml(Buffer) = 3bd1af04573ce2da7fc3dc04403e852e needed by ocaml-findlib-devel-1.6.2-1.5.i586
    (we have ocaml-runtime-4.05.0-1.1.i586)
  nothing provides ocaml(CamlinternalFormatBasics) = 9642e3ed163e46770985ca668738ed5f needed by ocaml-findlib-devel-1.6.2-1.5.i586
    (we have ocaml-runtime-4.05.0-1.1.i586)
  nothing provides ocaml(List) = ac5f6095cc0a546330ada0df0986a497 needed by ocaml-findlib-devel-1.6.2-1.5.i586
    (we have ocaml-runtime-4.05.0-1.1.i586)
  nothing provides ocaml(Pervasives) = 999b28e3b7638771c87eebf5a8325e42 needed by ocaml-findlib-devel-1.6.2-1.5.i586
    (we have ocaml-runtime-4.05.0-1.1.i586)
  nothing provides ocaml(String) = c28a3ca42a30c6ffa0bbab4a05329226 needed by ocaml-findlib-devel-1.6.2-1.5.i586
    (we have ocaml-runtime-4.05.0-1.1.i586)
  nothing provides ocaml(Sys) = c9608ce7bf745054a217110dcaac126e needed by ocaml-findlib-devel-1.6.2-1.5.i586
    (we have ocaml-runtime-4.05.0-1.1.i586)
  nothing provides ocaml(runtime) = 4.03.0 needed by ocaml-findlib-devel-1.6.2-1.5.i586
    (we have ocaml-runtime-4.05.0-1.1.i586)
  nothing provides ocaml(Int32) = d0de3bfd44513ff6fd70cbf476e9fa55 needed by ocaml-findlib-devel-1.6.2-1.5.i586
    (we have ocaml-runtime-4.05.0-1.1.i586)
  nothing provides ocaml(Map) = f23f0e2510f18d4b11ad6f7771618294 needed by ocaml-findlib-devel-1.6.2-1.5.i586
    (we have ocaml-runtime-4.05.0-1.1.i586)
  nothing provides ocaml(Obj) = bff9812925bc903e1896c82e123d0a17 needed by ocaml-findlib-devel-1.6.2-1.5.i586
    (we have ocaml-runtime-4.05.0-1.1.i586)
  nothing provides ocaml(Printf) = 0145d8daf24f9afd43ffac3c376fa3c4 needed by ocaml-findlib-devel-1.6.2-1.5.i586
    (we have ocaml-runtime-4.05.0-1.1.i586)
  nothing provides ocaml(Format) = 60c2e7663dd57d13b5920931742e1c10 needed by ocaml-findlib-devel-1.6.2-1.5.i586
    (we have ocaml-runtime-4.05.0-1.1.i586)
  nothing provides ocaml(Hashtbl) = 049026f8240c3b61bd91f719b0f55877 needed by ocaml-findlib-devel-1.6.2-1.5.i586
    (we have ocaml-runtime-4.05.0-1.1.i586)
  nothing provides ocaml(Lexing) = 330cec55af19abb867bbde7885b2588f needed by ocaml-findlib-devel-1.6.2-1.5.i586
    (we have ocaml-runtime-4.05.0-1.1.i586)
  nothing provides ocaml(Set) = a16cc25d9afe91eb22559bef41e9ee28 needed by ocaml-findlib-devel-1.6.2-1.5.i586
    (we have ocaml-runtime-4.05.0-1.1.i586)
  nothing provides ocaml(Stream) = d0b21ad0c1f4e93fa8c05b9ded519b52 needed by ocaml-findlib-devel-1.6.2-1.5.i586
    (we have ocaml-runtime-4.05.0-1.1.i586)
  nothing provides ocaml(Arg) = 819c4cecd433c434c2177432cc84a233 needed by ocaml-findlib-devel-1.6.2-1.5.i586
    (we have ocaml-runtime-4.05.0-1.1.i586)
  nothing provides ocaml(Location) = 691798779be44158297a5b82f6dee915 needed by ocaml-findlib-devel-1.6.2-1.5.i586
    (we have ocaml-compiler-libs-4.05.0-1.1.i586)
  nothing provides ocaml(Longident) = 0ccf17384b2613fc6a91e345eb296583 needed by ocaml-findlib-devel-1.6.2-1.5.i586
    (we have ocaml-compiler-libs-4.05.0-1.1.i586)
  nothing provides ocaml(Warnings) = c32410a2388b6ad31cd3275dc7647f1d needed by ocaml-findlib-devel-1.6.2-1.5.i586
    (we have ocaml-compiler-libs-4.05.0-1.1.i586)
  nothing provides ocaml(Filename) = 4d3fda93a4f9d9404ed1832e9422af42 needed by ocaml-findlib-devel-1.6.2-1.5.i586
    (we have ocaml-runtime-4.05.0-1.1.i586)
  nothing provides ocaml(Consistbl) = 786d8c5848d8ab4fbe030b3b8035df2f needed by ocaml-findlib-devel-1.6.2-1.5.i586
    (we have ocaml-compiler-libs-4.05.0-1.1.i586)
  nothing provides ocaml(Digest) = 23fdbfc720a71002434f407c37d040a3 needed by ocaml-findlib-devel-1.6.2-1.5.i586
    (we have ocaml-runtime-4.05.0-1.1.i586)
  nothing provides ocaml(Dynlink) = 449e61f07f7fbe4a981e2e16c8248682 needed by ocaml-findlib-devel-1.6.2-1.5.i586
    (we have ocaml-runtime-4.05.0-1.1.i586)
  nothing provides ocaml(Env) = a75a832d5a7ed4bb853b5e45538cade9 needed by ocaml-findlib-devel-1.6.2-1.5.i586
    (we have ocaml-compiler-libs-4.05.0-1.1.i586)
  nothing provides ocaml(Ident) = 56d27f338ad82340e795257d4558dc4b needed by ocaml-findlib-devel-1.6.2-1.5.i586
    (we have ocaml-compiler-libs-4.05.0-1.1.i586)
  nothing provides ocaml(Identifiable) = 5f3bb0e37dce1491306a817b4a9704c7 needed by ocaml-findlib-devel-1.6.2-1.5.i586
    (we have ocaml-compiler-libs-4.05.0-1.1.i586)
  nothing provides ocaml(Path) = e3ade1ff238aa4b3ce631874896d8c7b needed by ocaml-findlib-devel-1.6.2-1.5.i586
    (we have ocaml-compiler-libs-4.05.0-1.1.i586)
  nothing provides ocaml(Primitive) = 598ff1d6a08ffbda5bcc94c3f41d5486 needed by ocaml-findlib-devel-1.6.2-1.5.i586
    (we have ocaml-compiler-libs-4.05.0-1.1.i586)
  nothing provides ocaml(Subst) = 22d3104f267ee99c2799747a356f3066 needed by ocaml-findlib-devel-1.6.2-1.5.i586
    (we have ocaml-compiler-libs-4.05.0-1.1.i586)
  nothing provides ocaml(Topdirs) = e371e028e5b8e42ee7bfabb2ecd736b7 needed by ocaml-findlib-devel-1.6.2-1.5.i586
    (we have ocaml-runtime-4.05.0-1.1.i586)
    (we have ocaml-compiler-libs-4.05.0-1.1.i586)
  nothing provides ocaml(Toploop) = f06e0dfaffa1415a9333a8e04ef00663 needed by ocaml-findlib-devel-1.6.2-1.5.i586
    (we have ocaml-compiler-libs-4.05.0-1.1.i586)
  nothing provides ocaml(Types) = 59d3c9ab542c2a1f6c83ee128c2f20f6 needed by ocaml-findlib-devel-1.6.2-1.5.i586
    (we have ocaml-compiler-libs-4.05.0-1.1.i586)
  nothing provides ocaml(Big_int) = c12196f3cec618f38423d700e371079a needed by ocaml-findlib-devel-1.6.2-1.5.i586
    (we have ocaml-runtime-4.05.0-1.1.i586)
  nothing provides ocaml(Nat) = 980a74332f952248437a69e2f27624b4 needed by ocaml-findlib-devel-1.6.2-1.5.i586
    (we have ocaml-runtime-4.05.0-1.1.i586)
  nothing provides ocaml(Num) = 89fe7e94eec96d47fb227e3b41ef51b9 needed by ocaml-findlib-devel-1.6.2-1.5.i586
    (we have ocaml-runtime-4.05.0-1.1.i586)
  nothing provides ocaml(Ratio) = cac585400d78bc9862fcaa191b45a166 needed by ocaml-findlib-devel-1.6.2-1.5.i586
    (we have ocaml-runtime-4.05.0-1.1.i586)

can't install ocaml-brlapi-5.4-6.3.x86_64:
  package ocaml-brlapi-5.4-6.3.x86_64 requires ocamlfind(unix), but none of the providers can be installed
  package ocaml-findlib-1.6.2-1.5.x86_64 requires ocamlfind(num-top), but none of the providers can be installed
  nothing provides ocaml(Arg) = 819c4cecd433c434c2177432cc84a233 needed by ocaml-findlib-devel-1.6.2-1.5.x86_64
    (we have ocaml-runtime-4.05.0-1.1.x86_64)
  nothing provides ocaml(Buffer) = 3bd1af04573ce2da7fc3dc04403e852e needed by ocaml-findlib-devel-1.6.2-1.5.x86_64
    (we have ocaml-runtime-4.05.0-1.1.x86_64)
  nothing provides ocaml(CamlinternalFormatBasics) = 9642e3ed163e46770985ca668738ed5f needed by ocaml-findlib-devel-1.6.2-1.5.x86_64
    (we have ocaml-runtime-4.05.0-1.1.x86_64)
  nothing provides ocaml(Digest) = 23fdbfc720a71002434f407c37d040a3 needed by ocaml-findlib-devel-1.6.2-1.5.x86_64
    (we have ocaml-runtime-4.05.0-1.1.x86_64)
  nothing provides ocaml(Format) = 60c2e7663dd57d13b5920931742e1c10 needed by ocaml-findlib-devel-1.6.2-1.5.x86_64
    (we have ocaml-runtime-4.05.0-1.1.x86_64)
  nothing provides ocaml(Hashtbl) = 049026f8240c3b61bd91f719b0f55877 needed by ocaml-findlib-devel-1.6.2-1.5.x86_64
    (we have ocaml-runtime-4.05.0-1.1.x86_64)
  nothing provides ocaml(Lexing) = 330cec55af19abb867bbde7885b2588f needed by ocaml-findlib-devel-1.6.2-1.5.x86_64
    (we have ocaml-runtime-4.05.0-1.1.x86_64)
  nothing provides ocaml(List) = ac5f6095cc0a546330ada0df0986a497 needed by ocaml-findlib-devel-1.6.2-1.5.x86_64
    (we have ocaml-runtime-4.05.0-1.1.x86_64)
  nothing provides ocaml(Pervasives) = 999b28e3b7638771c87eebf5a8325e42 needed by ocaml-findlib-devel-1.6.2-1.5.x86_64
    (we have ocaml-runtime-4.05.0-1.1.x86_64)
  nothing provides ocaml(Set) = a16cc25d9afe91eb22559bef41e9ee28 needed by ocaml-findlib-devel-1.6.2-1.5.x86_64
    (we have ocaml-runtime-4.05.0-1.1.x86_64)
  nothing provides ocaml(String) = c28a3ca42a30c6ffa0bbab4a05329226 needed by ocaml-findlib-devel-1.6.2-1.5.x86_64
    (we have ocaml-runtime-4.05.0-1.1.x86_64)
  nothing provides ocaml(Sys) = c9608ce7bf745054a217110dcaac126e needed by ocaml-findlib-devel-1.6.2-1.5.x86_64
    (we have ocaml-runtime-4.05.0-1.1.x86_64)
  nothing provides ocaml(runtime) = 4.03.0 needed by ocaml-findlib-devel-1.6.2-1.5.x86_64
    (we have ocaml-runtime-4.05.0-1.1.x86_64)
  nothing provides ocaml(Int32) = d0de3bfd44513ff6fd70cbf476e9fa55 needed by ocaml-findlib-devel-1.6.2-1.5.x86_64
    (we have ocaml-runtime-4.05.0-1.1.x86_64)
  nothing provides ocaml(Map) = f23f0e2510f18d4b11ad6f7771618294 needed by ocaml-findlib-devel-1.6.2-1.5.x86_64
    (we have ocaml-runtime-4.05.0-1.1.x86_64)
  nothing provides ocaml(Printf) = 0145d8daf24f9afd43ffac3c376fa3c4 needed by ocaml-findlib-devel-1.6.2-1.5.x86_64
    (we have ocaml-runtime-4.05.0-1.1.x86_64)
  nothing provides ocaml(Array) = 3e56b0036c5d9e653763f3450236560d needed by ocaml-findlib-devel-1.6.2-1.5.x86_64
    (we have ocaml-runtime-4.05.0-1.1.x86_64)
  nothing provides ocaml(Filename) = 4d3fda93a4f9d9404ed1832e9422af42 needed by ocaml-findlib-devel-1.6.2-1.5.x86_64
    (we have ocaml-runtime-4.05.0-1.1.x86_64)
  nothing provides ocaml(Obj) = bff9812925bc903e1896c82e123d0a17 needed by ocaml-findlib-devel-1.6.2-1.5.x86_64
    (we have ocaml-runtime-4.05.0-1.1.x86_64)
  nothing provides ocaml(Stream) = d0b21ad0c1f4e93fa8c05b9ded519b52 needed by ocaml-findlib-devel-1.6.2-1.5.x86_64
    (we have ocaml-runtime-4.05.0-1.1.x86_64)
  nothing provides ocaml(Big_int) = c12196f3cec618f38423d700e371079a needed by ocaml-findlib-devel-1.6.2-1.5.x86_64
    (we have ocaml-runtime-4.05.0-1.1.x86_64)
  nothing provides ocaml(Consistbl) = 786d8c5848d8ab4fbe030b3b8035df2f needed by ocaml-findlib-devel-1.6.2-1.5.x86_64
    (we have ocaml-compiler-libs-4.05.0-1.1.x86_64)
  nothing provides ocaml(Dynlink) = 449e61f07f7fbe4a981e2e16c8248682 needed by ocaml-findlib-devel-1.6.2-1.5.x86_64
    (we have ocaml-runtime-4.05.0-1.1.x86_64)
  nothing provides ocaml(Env) = a75a832d5a7ed4bb853b5e45538cade9 needed by ocaml-findlib-devel-1.6.2-1.5.x86_64
    (we have ocaml-compiler-libs-4.05.0-1.1.x86_64)
  nothing provides ocaml(Ident) = 56d27f338ad82340e795257d4558dc4b needed by ocaml-findlib-devel-1.6.2-1.5.x86_64
    (we have ocaml-compiler-libs-4.05.0-1.1.x86_64)
  nothing provides ocaml(Identifiable) = 5f3bb0e37dce1491306a817b4a9704c7 needed by ocaml-findlib-devel-1.6.2-1.5.x86_64
    (we have ocaml-compiler-libs-4.05.0-1.1.x86_64)
  nothing provides ocaml(Location) = 691798779be44158297a5b82f6dee915 needed by ocaml-findlib-devel-1.6.2-1.5.x86_64
    (we have ocaml-compiler-libs-4.05.0-1.1.x86_64)
  nothing provides ocaml(Longident) = 0ccf17384b2613fc6a91e345eb296583 needed by ocaml-findlib-devel-1.6.2-1.5.x86_64
    (we have ocaml-compiler-libs-4.05.0-1.1.x86_64)
  nothing provides ocaml(Nat) = 980a74332f952248437a69e2f27624b4 needed by ocaml-findlib-devel-1.6.2-1.5.x86_64
    (we have ocaml-runtime-4.05.0-1.1.x86_64)
  nothing provides ocaml(Num) = 89fe7e94eec96d47fb227e3b41ef51b9 needed by ocaml-findlib-devel-1.6.2-1.5.x86_64
    (we have ocaml-runtime-4.05.0-1.1.x86_64)
  nothing provides ocaml(Path) = e3ade1ff238aa4b3ce631874896d8c7b needed by ocaml-findlib-devel-1.6.2-1.5.x86_64
    (we have ocaml-compiler-libs-4.05.0-1.1.x86_64)
  nothing provides ocaml(Primitive) = 598ff1d6a08ffbda5bcc94c3f41d5486 needed by ocaml-findlib-devel-1.6.2-1.5.x86_64
    (we have ocaml-compiler-libs-4.05.0-1.1.x86_64)
  nothing provides ocaml(Ratio) = cac585400d78bc9862fcaa191b45a166 needed by ocaml-findlib-devel-1.6.2-1.5.x86_64
    (we have ocaml-runtime-4.05.0-1.1.x86_64)
  nothing provides ocaml(Subst) = 22d3104f267ee99c2799747a356f3066 needed by ocaml-findlib-devel-1.6.2-1.5.x86_64
    (we have ocaml-compiler-libs-4.05.0-1.1.x86_64)
  nothing provides ocaml(Topdirs) = e371e028e5b8e42ee7bfabb2ecd736b7 needed by ocaml-findlib-devel-1.6.2-1.5.x86_64
    (we have ocaml-compiler-libs-4.05.0-1.1.x86_64)
    (we have ocaml-runtime-4.05.0-1.1.x86_64)
  nothing provides ocaml(Toploop) = f06e0dfaffa1415a9333a8e04ef00663 needed by ocaml-findlib-devel-1.6.2-1.5.x86_64
    (we have ocaml-compiler-libs-4.05.0-1.1.x86_64)
  nothing provides ocaml(Types) = 59d3c9ab542c2a1f6c83ee128c2f20f6 needed by ocaml-findlib-devel-1.6.2-1.5.x86_64
    (we have ocaml-compiler-libs-4.05.0-1.1.x86_64)
  nothing provides ocaml(Warnings) = c32410a2388b6ad31cd3275dc7647f1d needed by ocaml-findlib-devel-1.6.2-1.5.x86_64
    (we have ocaml-compiler-libs-4.05.0-1.1.x86_64)


Repo Checker

repo-checker wrote over 1 year ago

The version of this package in openSUSE:Leap:15.0 has installation issues and may not be installable:

can't install ocaml-brlapi-5.5-lp150.3.3.x86_64:
  package ocaml-4.05.0-lp150.1.19.x86_64 requires gcc, but none of the providers can be installed
  package ocaml-brlapi-5.5-lp150.3.3.x86_64 requires ocaml, but none of the providers can be installed
  package gcc-7-lp150.1.27.x86_64 requires gcc7, but none of the providers can be installed
  nothing provides libmpfr.so.4()(64bit) needed by gcc7-7.3.0+r257042-lp150.1.3.x86_64

G√ľnter Kraft

Guenter_K wrote 6 months ago

A new version -- 6.0 -- is available. http://mielke.cc/brltty/download.html#current - latest release!