Element Desktop

Edit Package element-desktop

Desktop electron based package for element web

Refresh
Refresh
Source Files
Filename Size Changed
_constraints 0000000129 129 Bytes
cargo.tar.gz 0227384297 217 MB
electron-v29.2.0-linux-x64.zip 0102650845 97.9 MB
element-desktop-1.11.64.tar.gz 0003203134 3.05 MB
element-desktop-yarn.lock 0000403612 394 KB
element-desktop.changes 0000001256 1.23 KB
element-desktop.spec 0000010412 10.2 KB
element-web-1.11.64.tar.gz 0002381515 2.27 MB
io.element.Element.desktop 0000000733 733 Bytes
node-pkgs-additional.tar.gz 0000000070 70 Bytes
node-pkgs.tar.gz 0217851313 208 MB
node-v29.2.0-headers.tar.gz 0000313076 306 KB
yarnrc 0000000065 65 Bytes
Comments 7

Ben Oua's avatar

I get an error when installing the latest version (1.11.23) on Fedora 37

Error: Transaction test error: file /usr/lib/.build-id/21/79f0c994368adf0e9287396aa6382939ef5866 from install of element-desktop-1.11.23-1.1.x86_64 conflicts with file from package python3-3.11.0-1.fc37.x86_64

Edit : Seems after running "dnf distro-sync", I can install it correctly...


James Bottomley's avatar

It looks like the fedora build doesn't separately package debuginfo. I have no idea why. Since it's highly unlikely we've found a hash collision, the build-id must be for the same component, so force installing should cause no problems


Steve Cossette's avatar

Would it be possible to enable Fedora 39 as a repo please? Thank you!



heiden maverick's avatar

May I kindly request that Fedora 39 be enabled as a repository? Much obliged. mini crossword


Chemal Pemial's avatar

[patch] Don't provide/require bundled libs

--- element-desktop.spec_orig   2024-04-12 09:32:44.002381693 +0200
+++ element-desktop.spec        2024-04-12 09:38:10.038198408 +0200
@@ -113,6 +113,9 @@

 %define debug_package %{nil}

+%global __provides_exclude ^libEGL\\.so.*$|^libGLESv2\\.so.*$|^libffmpeg\\.so.*$|^libvk_swiftshader\\.so.*$|^libvulkan\\.so.*$
+%global __requires_exclude ^libEGL\\.so.*$|^libGLESv2\\.so.*$|^libffmpeg\\.so.*$|^libvk_swiftshader\\.so.*$|^libvulkan\\.so.*$
+
 %description
 A glossy Matrix collaboration client - desktop

For the sake of sanity and because there is a chance that a package that requires (say) libvulkan.so.1 will pull this package instead of the right one.


Chemal Pemial's avatar

[patch] Remove another 400+ MB of unneeded stuff from resources/app.asar.unpacked/node_modules

--- element-desktop.spec_orig   2024-04-12 09:55:16.972752910 +0200
+++ element-desktop.spec        2024-04-12 09:53:10.394384671 +0200
@@ -264,6 +264,10 @@
     else
        rm -fr "$f"/native/target
        rm -fr "$f"/native/src
+       rm -rf "$f"/target
+       rm -rf "$f"/src
+       rm -rf "$f"/Cargo.*
+       rm -rf "$f"/.eslintrc.json
     fi
 done

openSUSE Build Service is sponsored by