Edit Package openblas

An optimized BLAS library based on GotoBLAS2

OpenBLAS is an optimized BLAS library based on GotoBLAS2 1.13 BSD version. The project is supported by the Lab of Parallel Software and Computational Science, ISCAS. http://www.rdcps.ac.cn

Refresh
Refresh
Source Files
Filename Size Changed
Define-sbgemm_r-to-fix-DYNAMIC_ARCH-builds.patch 0000001087 1.06 KB 3 months
Do-not-include-symbols-defined-in-driver-others-parameter.c-in-DYNAMIC_BUILD.patch 0000001300 1.27 KB 4 months
Fix-checks-for-AVX512-and-atomics.patch 0000001441 1.41 KB 3 months
OpenBLAS-0.3.20.tar.gz 0012742441 12.2 MB 4 months
README.HPC.SUSE 0000000889 889 Bytes almost 5 years
README.SUSE 0000000851 851 Bytes about 7 years
Remove-extraneous-and-wrong-definition-of-sbgemm_r-on-x86_64.patch 0000000825 825 Bytes 3 months
Revert-AVX512-capability-check-from-PR-1980-moved-to-build.patch 0000000948 948 Bytes 3 months
Use-CC-and-full-command-line-instead-of-hard-coding-gcc-for-AVX512-checking.patch 0000001128 1.1 KB 3 months
Utilize-compiler-AVX512-capability-info-from-c_check-when-building-getarch.patch 0000000943 943 Bytes 3 months
_constraints 0000000373 373 Bytes over 1 year
_multibuild 0000000180 180 Bytes 4 months
openblas-noexecstack.patch 0000001216 1.19 KB over 1 year
openblas-ppc64be_up2_p8.patch 0000003464 3.38 KB over 1 year
openblas-s390.patch 0000001363 1.33 KB over 1 year
openblas.changes 0000064900 63.4 KB about 2 months
openblas.spec 0000017341 16.9 KB about 2 months
Comments 4

Andre Barros's avatar

acobar wrote 12 months ago

Please, update to OpenBLAS to 3.17, as some optimizations were causing segfaults and reverted. See: https://github.com/xianyi/OpenBLAS/blob/develop/Changelog.txt.


Andre Barros's avatar

acobar wrote 12 months ago

It seems that octave 6.3.0 build failures (on test phase) may be associated to this on Tumbleweed.


Andre Barros's avatar

acobar wrote 12 months ago

OK, this really needs a better explanation. I have Tumbleweed and Leap 15.3 installed on different computers, and on both of them I use the Science repo to provide some more packages I need. Downgrading to default versions (3.13 on Leap and 3.14 on Tumbleweed) fixes the problem with Octave, as I was able to build version 6.3 and also run the tests (make check-local) without unknown failures. It probably affects other numerical packages too.

Regards, André


openSUSE Build Service is sponsored by