PDF Rendering Library

Edit Package poppler

Poppler is a PDF rendering library, forked from the xpdf PDF viewer
developed by Derek Noonburg of Glyph and Cog, LLC.

Refresh
Refresh
Source Files
Filename Size Changed
_multibuild 0000000077 77 Bytes
baselibs.conf 0000000000 0 Bytes
poppler-24.03.0.tar.xz 0001902068 1.81 MB
poppler-24.03.0.tar.xz.sig 0000000833 833 Bytes
poppler.changes 0000178147 174 KB
poppler.keyring 0000026823 26.2 KB
poppler.spec 0000011446 11.2 KB
reduce-boost-required-version.patch 0000000458 458 Bytes
reduce-libtiff-required-version.patch 0000000503 503 Bytes
Comments 4


Daniel Rivero Padilla's avatar

It seems to me that the package lacks some files which come in the original tar.xz. More especifically, there is a header (poppler-private.h) that is missing in the installed package (/usr/include/poppler/glib) that is present in the tar file from the official site.


Robert Riemann's avatar

Dears, since Okular 23.08, GPGME should be next to NSS be supported as PDF signing backend via poppler. Though I cannot see it. Is it maybe not activated in the poppler package?

Is it possible it has to be enabled at compile time? https://gitlab.freedesktop.org/poppler/poppler/-/merge_requests/1376/diffs#9a2aa4db38d3115ed60da621e012c0efc0172aae


Episteme PROMENEUR's avatar

With okular we cannot digital sign because okular does not find any gpg certificate. we need gpg backend not only NSS backend. we need that poppler is built with the gpgme support.

thanks

openSUSE Build Service is sponsored by